New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

removal of kombu-4.2.2 from pypi #974

Closed
prometheanfire opened this Issue Jan 2, 2019 · 4 comments

Comments

Projects
None yet
3 participants
@prometheanfire
Copy link

prometheanfire commented Jan 2, 2019

During/after 4.2.2-post1 was published 4.2.2 was removed. This broke openstack gate :| Was there a reason for it's removal?

https://storyboard.openstack.org/#!/story/2004685

@thedrow

This comment has been minimized.

Copy link
Member

thedrow commented Jan 2, 2019

The release was made from master by accident.
It contained code which should not have been released and causes errors in production.
We will create a more automated release process soon which will prevent such problems in the future.
My apologies for the inconvenience this may have caused.

@thedrow

This comment has been minimized.

Copy link
Member

thedrow commented Jan 2, 2019

See #996.

@nkuttler

This comment has been minimized.

Copy link

nkuttler commented Jan 2, 2019

Which release was made by accident, 4.2.2? Should we downgrade to 4.2.1 for now, or is post1 a proper release?

#996 doesn't seem to exist, but #966 does

Edit: Just to answer my own question, 4.2.2.post1 is the proper release according to #966

Jamim referenced this issue Jan 2, 2019

@prometheanfire

This comment has been minimized.

Copy link

prometheanfire commented Jan 2, 2019

ok, thanks. closing this in favor of #966

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment