Permalink
Browse files

don't test on 1.2.x anymore, ring 1.2.0 final requires Clojure 1.3 be…

…cause of tools.reader dep
  • Loading branch information...
1 parent 12d6921 commit 2f187dcf17767bc86437feae566fede4a9d33ed5 @cemerick committed Oct 1, 2013
Showing with 4 additions and 3 deletions.
  1. +4 −2 CHANGES.md
  2. +0 −1 project.clj
View
@@ -2,13 +2,15 @@
### `0.2.0`
+Friend now depends upon Ring 1.2.0 final. This means (due to the transitive
+dependency on [tools.reader](https://github.com/clojure/tools.reader)) that
+Friend now requires Clojure 1.3.0+.
+
This release contains a significant refactoring of the library to follow the
interceptor pattern adopted by Ring 1.2.0 (see the note under "Misc" below).
Note that this refactoring is _not_ a breaking change, either from an end-user
or workflow author/maintainer standpoint.
-Also, Friend now depends upon Ring 1.2.0 final.
-
**Core API**
* The `default-unauthenticated-handler` now properly retains the query string of
View
@@ -36,7 +36,6 @@
:sanity-check {:aot :all
:warn-on-reflection true
:compile-path "target/sanity-check-aot"}
- :1.2 {:dependencies [[org.clojure/clojure "1.2.0"]]}
:1.3 {:dependencies [[org.clojure/clojure "1.3.0"]]}
:1.5 {:dependencies [[org.clojure/clojure "1.5.1"]]}}
:aliases {"all" ["with-profile" "dev,1.2:dev,1.3:dev:dev,1.5"]

0 comments on commit 2f187dc

Please sign in to comment.