Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

.Net tests failing on Windows #44

Closed
woutersl opened this issue Jan 26, 2018 · 3 comments

Comments

@woutersl
Copy link
Member

commented Jan 26, 2018

Original report by Laurent Wouters (Bitbucket: 557058:675792b6-d731-4823-9f7d-c6dfcb2df2b5, ).


.Net tests seem to fail on Windows 10 while running with Mono for some reason. (everything is fine on Linux)

@woutersl

This comment has been minimized.

Copy link
Member Author

commented Jan 26, 2018

Original comment by Laurent Wouters (Bitbucket: 557058:675792b6-d731-4823-9f7d-c6dfcb2df2b5, ).


Verified

@woutersl

This comment has been minimized.

Copy link
Member Author

commented Jan 26, 2018

Original comment by Laurent Wouters (Bitbucket: 557058:675792b6-d731-4823-9f7d-c6dfcb2df2b5, ).


When executing tests, the parsers assembly for Rust (Parsers.dll on Windows) overwrite the parsers assembly for .Net (also Parsers.dll) ...
This does not happen on Linux because the parsers assembly for Rust is Parsers.so on Linux.

@woutersl

This comment has been minimized.

Copy link
Member Author

commented Jan 26, 2018

Original comment by Laurent Wouters (Bitbucket: 557058:675792b6-d731-4823-9f7d-c6dfcb2df2b5, ).


[fix] Fixed issue #44 .Net tests failing on Windows

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.