Skip to content
Permalink
Browse files

TST: travis: pin lxml version for py < 3.5

lxml 4.4.0 is not compatible with python 3.5
  • Loading branch information...
wagner-certat committed Jul 29, 2019
1 parent ecead3a commit 33f5c3baded3341be026333e24f54183c2681d8a
Showing with 5 additions and 2 deletions.
  1. +2 −1 .travis.yml
  2. +3 −1 CHANGELOG.md
@@ -19,7 +19,8 @@ install:
- set -e
- if [[ -v requirements ]]; then sudo apt-get install polipo lighttpd; fi
- if [[ $mode == debian ]]; then sudo apt-get install dpkg-dev dh-python python-setuptools python3-setuptools python3-all debhelper quilt fakeroot dh-systemd safe-rm; fi
- if [[ $requirements == true ]]; then for file in intelmq/bots/*/*/REQUIREMENTS.txt; do pip install -r $file; done; pip install lxml; fi
- if [[ $requirements == true ]]; then for file in intelmq/bots/*/*/REQUIREMENTS.txt; do pip install -r $file; done; fi
- if [[ $requirements == true ]]; then if [[ $TRAVIS_PYTHON_VERSION < '3.5' ]]; then pip install 'lxml<4.4.0'; else pip install lxml fi; fi
- if [[ $TRAVIS_PYTHON_VERSION < '3.5' ]]; then sudo pip install typing; fi
- if [[ -v requirements ]]; then pip install Cerberus!=1.3 codecov pyyaml; fi
- if [[ $mode == codestyle ]]; then pip install pycodestyle; fi
@@ -43,7 +43,9 @@ CHANGELOG
### Packaging

### Tests
- Travis: Use UTC timezone.
- Travis:
- Use UTC timezone.
- Limit lxml dependency on 3.4 to < 4.4.0 (incompatibility).

### Tools
- intelmqctl:

0 comments on commit 33f5c3b

Please sign in to comment.
You can’t perform that action at this time.