Skip to content
Permalink
Browse files

TST: Fix travis build errors: remove lxml ifs

install the lxml library from the requirements file and mark the
compatible python versions there.
Does not work in the travis file
  • Loading branch information...
wagner-certat committed Aug 22, 2019
1 parent ab09624 commit 3662c7d020c6499eccf2b68fa8a490ab7c04d76a
Showing with 2 additions and 1 deletion.
  1. +0 −1 .travis.yml
  2. +2 −0 intelmq/bots/parsers/html_table/REQUIREMENTS.txt
@@ -20,7 +20,6 @@ install:
- if [[ -v requirements ]]; then sudo apt-get install polipo lighttpd; fi
- if [[ $mode == debian ]]; then sudo apt-get install dpkg-dev dh-python python-setuptools python3-setuptools python3-all debhelper quilt fakeroot dh-systemd safe-rm; fi
- if [[ $requirements == true ]]; then for file in intelmq/bots/*/*/REQUIREMENTS.txt; do pip install -r $file; done; fi
- if [[ $requirements == true ]]; then if [[ $TRAVIS_PYTHON_VERSION < '3.5' ]]; then pip install 'lxml<4.4.0'; else pip install lxml fi; fi
- if [[ $TRAVIS_PYTHON_VERSION < '3.5' ]]; then sudo pip install typing; fi
- if [[ -v requirements ]]; then pip install Cerberus!=1.3 codecov pyyaml; fi
- if [[ $mode == codestyle ]]; then pip install pycodestyle; fi
@@ -1 +1,3 @@
beautifulsoup4
lxml<4.4.0; python_version < '3.5'
lxml; python_version >= '3.5'

0 comments on commit 3662c7d

Please sign in to comment.
You can’t perform that action at this time.