New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Plugin issue where two digit version number not recognized by cfwheels correctly. #840

Closed
18thAvenue opened this Issue Jan 26, 2018 · 2 comments

Comments

3 participants
@18thAvenue

18thAvenue commented Jan 26, 2018

Using cfwheels 2.0 plugins that have this.version = "2.0"; still shows the red "this plugin might not be supported" in debug bar. If you change the plugin to say this.version = "2.0.0" it goes away.

@perdjurner perdjurner added this to the 2.0.1 milestone Jan 27, 2018

neokoenig added a commit that referenced this issue Jan 30, 2018

@neokoenig

This comment has been minimized.

Member

neokoenig commented Jan 30, 2018

Think I've fixed this, but please check. It should do:
If plugin author has specified 2.0.0 then check against the full wheels version, as it should always be 3 parts long with semver; if they've put 2.0 then only check against the major/minor version

@18thAvenue

This comment has been minimized.

18thAvenue commented Jan 30, 2018

Hi,
It works! Thanks. I also tried changing the version in the plugin to 2.0 and 2.0.0 and they both work.

@neokoenig neokoenig closed this Jan 31, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment