Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Development environment cleanup #16

Merged
merged 2 commits into from

2 participants

@tmorton

These two things were needed for me to get the specs running (using ruby 1.8.7-352). Fixed syntax and added "rake" as a dependency.

@chad chad merged commit 5153f08 into from
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
This page is out of date. Refresh to see the latest.
View
6 spec/turbulence/scatter_splot_generator_spec.rb
@@ -60,12 +60,12 @@
spg.stub(:metrics_hash).and_return("foo.rb" => {
Turbulence::Calculators::Churn => 1
})
- spg.grouped_by_directory.should == {"." => [["foo.rb", Turbulence::Calculators::Churn => 1]]}
+ spg.grouped_by_directory.should == {"." => [["foo.rb", {Turbulence::Calculators::Churn => 1}]]}
end
it "takes full path into account" do
- spg.grouped_by_directory.should == {"lib/foo" => [["lib/foo/foo.rb", Turbulence::Calculators::Churn => 1]],
- "lib" => [["lib/bar.rb", Turbulence::Calculators::Churn => 2]]}
+ spg.grouped_by_directory.should == {"lib/foo" => [["lib/foo/foo.rb", {Turbulence::Calculators::Churn => 1}]],
+ "lib" => [["lib/bar.rb", {Turbulence::Calculators::Churn => 2}]]}
end
end
View
1  turbulence.gemspec
@@ -14,6 +14,7 @@ Gem::Specification.new do |s|
s.add_dependency "launchy", "~> 2.0.0"
s.add_dependency "ParseTree", "~> 3.0.7"
s.add_development_dependency 'rspec', '~> 2.6.0'
+ s.add_development_dependency 'rake'
s.summary = %q{Automates churn + flog scoring on a git repo for a Ruby project}
s.description = %q{Based on this http://www.stickyminds.com/sitewide.asp?Function=edetail&ObjectType=COL&ObjectId=16679&tth=DYN&tt=siteemail&iDyn=2}
Something went wrong with that request. Please try again.