Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade tty-table to fix deprecation warning of smartwrap transient dep #796

Merged
merged 4 commits into from Jun 6, 2022

Conversation

JakeGinnivan
Copy link
Contributor

@JakeGinnivan JakeGinnivan commented May 1, 2022

when installing Changesets, get

 WARN  deprecated smartwrap@1.2.5

The pnpm why shows:

@changesets/cli 2.20.0
└─┬ tty-table 2.8.13
└── smartwrap 1.2.5

Looks like API is all compatible, the TS definitions in the tty-table are wrong (requires the formatter prop, which isn't required) so I left the type defs which are in the repo

@changeset-bot
Copy link

changeset-bot bot commented May 1, 2022

🦋 Changeset detected

Latest commit: 4258b2d

The changes in this PR will be included in the next version bump.

This PR includes changesets to release 1 package
Name Type
@changesets/cli Minor

Not sure what this means? Click here to learn what changesets are.

Click here if you're a maintainer who wants to add another changeset to this PR

@codesandbox-ci
Copy link

codesandbox-ci bot commented May 1, 2022

This pull request is automatically built and testable in CodeSandbox.

To see build info of the built libraries, click here or the icon next to each commit SHA.

Latest deployment of this branch, based on commit 4258b2d:

Sandbox Source
Vanilla Configuration

@JakeGinnivan
Copy link
Contributor Author

JakeGinnivan commented May 1, 2022

It looks like this causes a cascade of new deps to be installed because of other out of date dependencies :(
Thoughts?

@benmccann benmccann mentioned this pull request May 5, 2022
@Andarist
Copy link
Member

Andarist commented May 21, 2022

The biggest concern for this is that this (and related upgrades) bump a node version requirement - and I'm still on the fence about what to do about it. If we could maintain compat with node 12 that would be kinda sweet. Tracking this stuff through layers of packages is time-consuming though :s

@benmccann
Copy link
Contributor

benmccann commented May 21, 2022

Ah, that's helpful context. Though every project I work on has dropped Node 12 support

@JakeGinnivan
Copy link
Contributor Author

JakeGinnivan commented May 22, 2022

I think node12 will be dropped rather rapidly due to the ESM changes.

Once node 18 goes LTS I think dropping 12 is fine because 12 will be 3 LTS versions behind.

The trade off is being unable to fix security advisories and deprecations because the upgrades become too many.

Also the build error is due to node10 not 12.

image

If there are matrix builds testing node12, 14, 16, 18 then we can upgrade, if the CI passes then go forward?

.changeset/healthy-dogs-repair.md Outdated Show resolved Hide resolved
.changeset/healthy-dogs-repair.md Outdated Show resolved Hide resolved
@Andarist Andarist merged commit 745b771 into changesets:main Jun 6, 2022
0 of 4 checks passed
@github-actions github-actions bot mentioned this pull request Jun 6, 2022
@JakeGinnivan JakeGinnivan deleted the chore/upgrade-tty-table branch Jun 30, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants