A new emacs settings compatible with emacs 25.x [ONLY]
Emacs Lisp Python
Switch branches/tags
Nothing to show
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
plugins
settings
snippets @ e481b6b
themes
.gitignore
.gitmodules
README.org
emacs-dealM.el

README.org

README

Useful Custom variables

(setq default-theme-r 'monokai
      default-source-font-r "Source Code Pro-12")

packages.

All packages will be put inside a plugin folder.

Install procudure.

add emacs-dealM.el to your .emacs.

ex:

(load-file "/path/to/emacs-dealM.el")

Tested Environment

Mac OS X 10.10 + emacs 25.1.1

Something out of the project.

You may need to add this thing by your own.

  1. fonts: Adobe Source Code Pro for English.
  2. Install python package by your own:
  3. pip install epc if you want to use jedi server
  4. If you have met (Error: No word lists can be found for the language “en_US”.) install flymake lib aspell-en.
    pacman -S aspell-en
        
  5. pip install epc jedi pep8 pyflakes autopep8 (preferrably in virtualenv) to make most of python-mode

Speacial System Support

typescript

npm install -g clausreinke/typescript-tools

config HTML stuff

  • If you want Flymake run, you need install tidy in your system’s path.(HTML tool)
  • If you use HTML5 to write pages, you can download html tidy from github.

list:

  1. try anaconda-mode for python.
  2. try c-ide for C.

about this project

This project is about emacs settings ONLY for emacs 25.1 I majorly use this settings in mac OS X/Linux, but the setting should not break windows version emacs.