Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Problem compiling less.ls #7

Open
fritzsche opened this Issue · 3 comments

4 participants

@fritzsche

Hi Charlie,

not really an issue of twostroke, just I thought I report this here in case somebody is trying the same:
I just tried to compile less.js ( https://github.com/cloudhead/less.js/blob/master/dist/less-1.2.0.js ),
well and it's amazing that it almost works.
I just receive one syntax error in line 1997 and after looking on the source I notice that it might be an issue on less.js side as there is a missing ";" on the line before.
As I understand most common Javascript VM's are ignoring such issues. What about twostroke?
Good news is after manually fixing this javascript error I could compile the less framework. (have not checked jet if it works in the runtime).
Thanks, Thomas

@charliesome
Owner

This is an issue with Twostroke lacking semicolon insertion

@toadkicker toadkicker referenced this issue in seyhunak/twitter-bootstrap-rails
Closed

Remove therubyracer dependecy #336

@toadkicker

I'm looking at using this to support twitter-bootstrap-rails gem so we can remove therubyracer from being a dependency. (ref: seyhunak/twitter-bootstrap-rails#336). This would fix a bunch of issues if we can figure out a way to run less.js without the upstream dependency on therubyracer. Any tips/advice are welcome!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.