Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Creating an install generator

  • Loading branch information...
commit 3942690a12c5f80ba1daef4cadcef366a42326d1 0 parents
@svileng svileng authored
4 .gitignore
@@ -0,0 +1,4 @@
+*.gem
+.bundle
+Gemfile.lock
+pkg/*
4 Gemfile
@@ -0,0 +1,4 @@
+source "http://rubygems.org"
+
+# Specify your gem's dependencies in announcements.gemspec
+gemspec
1  Rakefile
@@ -0,0 +1 @@
+require "bundler/gem_tasks"
24 announcements.gemspec
@@ -0,0 +1,24 @@
+# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "announcements/version"
+
+Gem::Specification.new do |s|
+ s.name = "announcements"
+ s.version = Announcements::VERSION
+ s.authors = ["Svilen Gospodinov"]
+ s.email = ["svilen@gospodinov.co.uk"]
+ s.homepage = ""
+ s.summary = %q{TODO: Write a gem summary}
+ s.description = %q{TODO: Write a gem description}
+
+ s.rubyforge_project = "announcements"
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
+
+ # specify any dependencies here; for example:
+ # s.add_development_dependency "rspec"
+ # s.add_runtime_dependency "rest-client"
+end
5 lib/announcements.rb
@@ -0,0 +1,5 @@
+require "announcements/version"
+
+module Announcements
+ # Your code goes here...
+end
3  lib/announcements/version.rb
@@ -0,0 +1,3 @@
+module Announcements
+ VERSION = "0.0.1"
+end
8 lib/generators/install/install_generator.rb
@@ -0,0 +1,8 @@
+module Announcements
+ class InstallGenerator < Rails:Generators:Base
+ desc <<-DESC
+ Description:
+ Blablabla
+ DESC
+ end
+end
Please sign in to comment.
Something went wrong with that request. Please try again.