Skip to content

iPhone Debug and simulator not work?must release at itunes Store? #2

Open
androidcn opened this Issue Oct 21, 2012 · 4 comments

2 participants

@androidcn

iPhone Debug and simulator not work?must release at itunes Store?

@chebum
Owner
chebum commented Oct 21, 2012

It works on my machine. Did you set settings.Debug to true when checking?

@androidcn
@chebum
Owner
chebum commented Oct 22, 2012

Hi,

As far as I can see, it appears correctly: http://i.imgur.com/oEJ9l.png
Here is my setup code:

AppiraterSettings settings = new AppiraterSettings (123454656);
settings.AppName = (NSString) NSBundle.MainBundle.InfoDictionary.ObjectForKey (new NSString ("CFBundleDisplayName"));
settings.Message = string.Format ("Rate-Message".t (), settings.AppName);
settings.MessageTitle = string.Format ("Rate-Title".t (), settings.AppName);
settings.CancelButton = "Rate-CancelButton".t ();
settings.RateButton = string.Format ("Rate-RateButton".t (), settings.AppName);
settings.RateLaterButton = "Rate-RateLaterButton".t ();
settings.DaysUntilPrompt = 7;
settings.UsesUntiPrompt = 5;
#if DEBUG
settings.Debug = true;
#endif
appirater = new Appirater (settings);

Please try to copy it entirely and see if this solves the problem. If it doesn't, prepare a sample project that reproduces the problem and send it to me. There should be no extra stuff like ORM, 3rd party libraries, etc. Just the code you use to setup appirater and it should show the problem.

Thanks,
Ivan

@androidcn
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.