@tsjensen tsjensen released this Jul 7, 2017 · 32 commits to master since this release

Assets 11

Adds support for Checkstyle 8.0.

This is a major change (new major version), because the Checkstyle API was changed in a way that cannot be compensated by our internal CheckstyleApiFixer. The following changes result for Checkstyle Addons users:

  • Checkstyle versions 6.15 and older are no longer supported.
  • Support for legacy SonarQube versions had to be dropped, so we now require at least the SonarQube Checkstyle plugin version 3.1, which means that SonarQube itself must be at least 4.5.2 (up from 4.5.1) and run on Java 8.
  • The Checkstyle Addons sources are now Java 7 (the checked source code may still be at any level ≤ 8).
  • Java 7 is still supported via the *-java7 artifacts, but only for Checkstyle versions 6.16.1 - 6.19, and without SonarQube.

This release is functionally equivalent to the previous v4.2.0, so at the moment, you need to upgrade only if you require Checkstyle 8.0 support.

[Which files to choose for download?]