Skip to content
Browse files

Only use entry_points if we're on Windows; hopefully this corrects kb…

…@'s issues
  • Loading branch information...
1 parent 40fd6ac commit 1b1b4cb083ac07d8347b0d4f4a1c9bb2a621284f R. Tyler Ballance committed Sep 1, 2009
Showing with 10 additions and 7 deletions.
  1. +10 −7 SetupConfig.py
View
17 SetupConfig.py
@@ -1,4 +1,6 @@
#-------Main Package Settings-----------#
+import sys
+
name = 'Cheetah'
from cheetah.Version import Version as version
maintainer = "R. Tyler Ballance"
@@ -59,13 +61,14 @@
install_requires = [
"Markdown >= 2.0.1",
]
- # use 'entry_points' instead of 'scripts'
- del scripts
- entry_points = {
- 'console_scripts': [
- 'cheetah = Cheetah.CheetahWrapper:_cheetah',
- 'cheetah-compile = Cheetah.CheetahWrapper:_cheetah_compile',
- ]
+ if sys.platform == 'win32':
+ # use 'entry_points' instead of 'scripts'
+ del scripts
+ entry_points = {
+ 'console_scripts': [
+ 'cheetah = Cheetah.CheetahWrapper:_cheetah',
+ 'cheetah-compile = Cheetah.CheetahWrapper:_cheetah_compile',
+ ]
}
except ImportError:
print 'Not using setuptools, so we cannot install the Markdown dependency'

0 comments on commit 1b1b4cb

Please sign in to comment.
Something went wrong with that request. Please try again.