New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Kattello Agent install fails because the repo isn't registered yet #25

Closed
TheLunaticScripter opened this Issue May 17, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@TheLunaticScripter

TheLunaticScripter commented May 17, 2017

Issue

When registering a new node the katello-agent installs but it is not able to pull down the .rpm because the repo where has not been registered yet.

Cookbook Code

rhsm_register node['etp_oraunix_mgmt']['rhel_satellite_host'] do
  organization '<Organization>'
  activation_key 'rhel_7'
  satellite_host node['etp_oraunix_mgmt']['rhel_satellite_host']
end

rhsm_repo '\*-satellite-tools-\*-rpms' do
  action :enable
end

Attempted Workarounds

I attempted to move the repo add above the registration and that failed because it didn't know where the repo is.

@donwlewis

This comment has been minimized.

Show comment
Hide comment
@donwlewis

donwlewis Jun 7, 2017

Contributor

So another way around this would be to make sure the repo is is enabled with your activation key. I generally disable the katello-agent install, and add that to my base cookbook for all utilities.

Contributor

donwlewis commented Jun 7, 2017

So another way around this would be to make sure the repo is is enabled with your activation key. I generally disable the katello-agent install, and add that to my base cookbook for all utilities.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment