Permalink
Browse files

Temporarily force rubygems 2.1.x for travis

This works around an incompatibility between bundler, rubygems 2.2.0,
and ruby 1.8.7.
  • Loading branch information...
1 parent 217ecc6 commit cf57ac7d20df3dee300e33d60dda751c32e59572 @danielsdeleo danielsdeleo committed Jan 2, 2014
Showing with 14 additions and 1 deletion.
  1. +14 −1 .travis.yml
View
@@ -1,6 +1,19 @@
+# Temporary workaround for issue with rubygems 2.2.0 with bundler 1.5 on ruby
+# 1.8.7.
+#
+# A fix has been merged to rubygems but not yet released. See:
+# https://github.com/rubygems/rubygems/commit/f8e0f1d5f67cfc4e1966cc1e2db367aebf8a09e4
+#
+# See also CHEF-4916
+#
+# This workaround should be removed when that fix is released.
+before_install:
+ - gem update --system 2.1.11
+ - gem --version
+
rvm:
- 1.8.7
- 1.9.2
- 1.9.3
-script: bundle exec rake spec
+script: bundle exec rake spec

0 comments on commit cf57ac7

Please sign in to comment.