Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

[unity-tweak-tool] Added

  • Loading branch information...
commit 52e1f2e56ccf0394037ee91188a65c7b938e796f 1 parent e0ae038
@chenxiaolong authored
View
41 README
@@ -23,32 +23,33 @@ Applications
16: indicator-cpufreq -> CPU Frequency Indicator
17: empathy-ubuntu -> Empathy IM client with UOA support
18: telepathy-indicator -> Telepathy integration with the msg menu
+19: unity-tweak-tool -> Tool to configure the Unity desktop
Unity Webapps
-19: python-polib -> Python library for messing with po files
-20: webapps-applications -> Unity WebApps integration scripts
-21: webapps-greasemonkey -> Firefox extension for user scripts
-22: unity-firefox-extension -> Firefox extension for Unity integration
-23: webaccounts-browser-extension -> Web Accounts extension for FF and Chromium
-24: unity-webapps -> See PKGBUILD for list of WebApps
+20: python-polib -> Python library for messing with po files
+21: webapps-applications -> Unity WebApps integration scripts
+22: webapps-greasemonkey -> Firefox extension for user scripts
+23: unity-firefox-extension -> Firefox extension for Unity integration
+24: webaccounts-browser-extension -> Web Accounts extension for FF and Chromium
+25: unity-webapps -> See PKGBUILD for list of WebApps
LightDM remote session
-25: python3-pycurl -> A Python 3 interface to libcurl
-26: thin-client-config-agent -> Retrieve list of remote servers for a user
-27: remote-login-service -> Service to track the remote servers to use
-28: lightdm-remote-session-uccsconfigure -> Session to configure UCCS
-29: libpam-freerdp -> PAM module to auth. against an RDP server
-30: lightdm-remote-session-freerdp -> Session to login in with FreeRDP
+26: python3-pycurl -> A Python 3 interface to libcurl
+27: thin-client-config-agent -> Retrieve list of remote servers for a user
+28: remote-login-service -> Service to track the remote servers to use
+29: lightdm-remote-session-uccsconfigure -> Session to configure UCCS
+30: libpam-freerdp -> PAM module to auth. against an RDP server
+31: lightdm-remote-session-freerdp -> Session to login in with FreeRDP
Everpad
-31: python-shiboken -> CPython bindings generator for C++ libs
-32: python-pyside -> Python bindings for Qt
-33: unity-singlet -> Python library for building lenses & scopes
-34: python-keyring -> Python library for accessing keyrings
-35: python2-oauth2 -> Python 2 library for OAuth 1.0
-36: python2-magic -> Python 2 bindings for file
-37: python-regex -> Alternative Python regular expression module
-38: everpad -> Evernote client with Unity integration
+32: python-shiboken -> CPython bindings generator for C++ libs
+33: python-pyside -> Python bindings for Qt
+34: unity-singlet -> Python library for building lenses & scopes
+35: python-keyring -> Python library for accessing keyrings
+36: python2-oauth2 -> Python 2 library for OAuth 1.0
+37: python2-magic -> Python 2 bindings for file
+38: python-regex -> Alternative Python regular expression module
+39: everpad -> Evernote client with Unity integration
All of the PKGBUILD's have been checked with the namcap tool for consistency.
View
23 unity-tweak-tool/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+pkgname=unity-tweak-tool
+pkgver=0.0.3
+pkgrel=1
+pkgdesc="Configuration tool for the Unity desktop"
+arch=('any')
+url="https://github.com/freyja-dev/unity-tweak-tool"
+license=('GPL')
+groups=('unity-extra')
+depends=('glib2' 'gtk3' 'hicolor-icon-theme' 'python' 'python-xdg' 'unity')
+makedepends=('python-distutils-extra')
+options=('!emptydirs')
+install=${pkgname}.install
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/unity-tweak-tool_${pkgver}.tar.gz")
+sha512sums=('119708e14be741f1ed5b8d9e2da39ce52e872eb9ff8f7226a20362a17f08deee7ac2f30afa5a9d325d6a4e0122f4d546fb77a0661942a8591382ab55d075d9dc')
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et:
View
8 unity-tweak-tool/compare_versions.sh
@@ -0,0 +1,8 @@
+#!/usr/bin/env bash
+
+source "$(dirname ${0})/PKGBUILD"
+source "$(dirname ${0})/../version_checker.sh"
+
+echo -e "PKGBUILD version: ${pkgver}"
+echo -e "Upstream version: (none: native package)"
+echo -e "Ubuntu version: $(get_ubuntu_version ${pkgname} ${1:-raring} native)"
View
12 unity-tweak-tool/unity-tweak-tool.install
@@ -0,0 +1,12 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas/
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor/
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
Please sign in to comment.
Something went wrong with that request. Please try again.