Skip to content
This repository
Fetching contributors…

Cannot retrieve contributors at this time

executable file 141 lines (115 sloc) 3.544 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141
#!/bin/sh
# Run this to generate all the initial makefiles, etc.

# Exit on error
set -e

# Exit on pipe fails (if possible)
( set -o pipefail 2> /dev/null ) || true

# Basedir
srcdir=`dirname $0`
test -z "$srcdir" && srcdir=.

ORIGDIR=`pwd`
cd $srcdir
PROJECT=cherokee

#include our own macros
if test x"$ACLOCAL_FLAGS" != "x"; then
    ACLOCAL_FLAGS="$ACLOCAL_FLAGS -I m4"
else
    ACLOCAL_FLAGS="-I m4"
fi

# Check for the tools
DIE=0

test -z "$AUTOMAKE" && AUTOMAKE=automake
test -z "$ACLOCAL" && ACLOCAL=aclocal
test -z "$AUTOCONF" && AUTOCONF=autoconf
test -z "$AUTOHEADER" && AUTOHEADER=autoheader

if hash glibtool 2>&-; then
 test -z "$LIBTOOL" && LIBTOOL=glibtool
 test -z "$LIBTOOLIZE" && LIBTOOLIZE=glibtoolize
else
 test -z "$LIBTOOL" && LIBTOOL=libtool
 test -z "$LIBTOOLIZE" && LIBTOOLIZE=libtoolize
fi

($AUTOCONF --version) < /dev/null > /dev/null 2>&1 || {
    echo
echo "You must have autoconf installed to compile $PROJECT."
    echo "Download the appropriate package for your distribution,"
    echo "or get the source tarball at ftp://ftp.gnu.org/pub/gnu/"
    DIE=1
}

($LIBTOOL --version) < /dev/null > /dev/null 2>&1 || {
    echo
echo "You must have libtool installed to compile $PROJECT."
    echo "Download the appropriate package for your distribution, or"
    echo "get http://ftp.gnu.org/gnu/libtool/libtool-2.2.6a.tar.gz"
    echo "(or a newer version if it is available)"
    DIE=1
}

($AUTOMAKE --version) < /dev/null > /dev/null 2>&1 || {
    echo
echo "You must have automake installed to compile $PROJECT."
    echo "Download the appropriate package for your distribution, or"
    echo "get http://ftp.gnu.org/gnu/automake/automake-1.10.2.tar.gz"
    echo "(or a newer version if it is available)"
    DIE=1
}

if test "$DIE" -eq 1; then
    exit 1
fi

# Update the POTFILES.in
echo "Generating a fresh po/admin/POTFILES.in file.."
po/admin/generate_POTFILESin.py > po/admin/POTFILES.in

# No arguments warning
if test -z "$*"; then
    echo "WARNING: I'm going to run ./configure with no arguments - if you wish "
    echo "to pass any to it, please specify them on the $0 command line."
    echo
fi

case $CC in
*xlc | *xlc\ * | *lcc | *lcc\ *) am_opt=--include-deps;;
esac

if test -z "$ACLOCAL_FLAGS"; then

acdir=`$ACLOCAL --print-ac-dir`
     m4list="etr_socket_nsl.m4 network.m4 sendfile_samba.m4 pwd_grp.m4 mysql.m4"

for file in $m4list
do
if [ ! -f "$acdir/$file" ]; then
echo "WARNING: aclocal's directory is $acdir, but..."
echo " no file $acdir/$file"
echo " You may see fatal macro warnings below."
echo " If these files are installed in /some/dir, set the ACLOCAL_FLAGS "
echo " environment variable to \"-I /some/dir\", or install"
echo " $acdir/$file."
echo ""
fi
done
fi

# Libtool
if grep "^AM_PROG_LIBTOOL" configure.in >/dev/null; then
  echo "Running: libtoolize --force --copy..."
  $LIBTOOLIZE --force --copy
fi

# Aclocal
echo "Running: $ACLOCAL $ACLOCAL_FLAGS..."
rm -f aclocal.m4
$ACLOCAL $ACLOCAL_FLAGS

# Autoheader
if grep "^AM_CONFIG_HEADER" configure.in >/dev/null; then
  echo "Running: autoheader..."
  $AUTOHEADER
fi

# Automake
# --foreign = Do not enforce GNU standards
# (ChangeLog, NEWS, THANKS, etc. files)
echo "Running: automake -a $am_opt..."
$AUTOMAKE -a --foreign $am_opt

# Autoconf
echo "Running: autoconf..."
$AUTOCONF

# ./configure
if test x$NO_CONFIGURE != x; then
  exit;
fi

cd $ORIGDIR
$srcdir/configure "$@"

echo
echo "Now type 'make' to compile $PROJECT."
Something went wrong with that request. Please try again.