503 bad gateway - Ubuntu 11.04 on Linode VPS #843

Closed
Borkason opened this Issue Mar 24, 2013 · 7 comments

1 participant

@Borkason
Cherokee Project member

Original author: nilsen.s...@gmail.com (July 01, 2011 03:35:29)

What steps will reproduce the problem?
1. Install Cherokee from Launchpad (1.2.98-1 natty)
2. Install with necessary dependencies
3. Run cherokee-admin -b and get 503

What is the expected output? What do you see instead?
The expected output would be to see the admin interface, and not get a 503 bad gateway instead.

What version of the product are you using? On what operating system?
Ubuntu 11.04 fresh install, 2.6.39.1 32-bit core running Cherokee 1.2.98~1 natty from Launchpad.

Please provide any additional information below.
Well, after I installed the Cherokee from Launchpad and again got the 503 error (I tried this once before and rebuild Linux to do this) I removed the ppa-link and installed cherokee from the Ubuntu repositories (1.0.8-4) and everything works. I don't know if this is a problem with the linux image from Linode or something with the version from Launchpad or something else completely, but since it's just affecting the one from Launchpad and the install is clean five minutes ago I don't really know what the issue is.

Original issue: http://code.google.com/p/cherokee/issues/detail?id=1225

@Borkason
Cherokee Project member

From lnu...@gmail.com on July 01, 2011 11:06:15
This is my setup on one linode :

Linux kdx 2.6.38.3-linode3​1 (Github: #​81 (Github: #147)) #​1 (Github: #​81 (Github: #147)) SMP Thu Apr 21 20:08:53 UTC 2011 i686 i686 i386 GNU/Linux

ii cherokee 1.2.98-1~natty~ppa1 Very fast, flexible and easy to configure web server
ii cherokee-admin 1.2.98-1~natty~ppa1 Cherokee web server - Administrative plugin
ii libcherokee-base0 1.2.98-1~natty~ppa1 Cherokee web server - Base libraries
ii libcherokee-client0 1.2.98-1~natty~ppa1 Cherokee web server - Client libraries
ii libcherokee-mod-libssl 1.2.98-1~natty~ppa1 Cherokee web server - SSL crypto functions plugin
ii libcherokee-mod-rrd 1.2.98-1~natty~ppa1 Cherokee web server - RRDtool based information collector
ii libcherokee-server0 1.2.98-1~natty~ppa1 Cherokee web server - Server libraries

All is working fine
tested cherokee-admin -b and is working.

Can you please test with a new cherokee.conf file to see if there's a bug with the cherokee.conf update

saludos

@Borkason
Cherokee Project member

From nilsen.s...@gmail.com on July 01, 2011 12:06:05
Okay, so I installed all the libraries that you mention and downloaded the cherokee.conf.sample.pre from the Subversion trunk and retried. Same error, 503 bad gateway. And I went back, purged the cherokee from Launchpad and reinstalled from the Ubuntu repositories, and from there it works (1.0.8).

I do notice that you are using 2.6.38.3 while I'm using 2.6.39.1, could that have anything to do with it? Also, what distribution are you using?

@Borkason
Cherokee Project member

From lnu...@gmail.com on July 01, 2011 13:19:44
Rebooted to the newest kernel

Linux kdx 2.6.39.1-linode3​1 (Github: #​81 (Github: #147)) #​1 (Github: #​81 (Github: #147)) SMP Tue Jun 21 10:29:24 EDT 2011 i686 i686 i386 GNU/Linux

All working fine here this is working with ubuntu natty and all updates applied

@Borkason
Cherokee Project member

From nilsen.s...@gmail.com on July 01, 2011 22:10:02
Dang it, this is really weird. I purged the cherokee from the repositories and rebuilt from source and still a 503 bad gateway when I'm trying to access the admin interface. Everything else works just fine. Okay, so the process I did in the beginning is to update my hostname, update my /etc/hosts file to the corresponding hostname and domain names, update timezone, install updates, add launchpad ppa and install cherokee and it doesn't work.

I'll try to install Ubuntu 10.04 LTS and see if that works, and if it does I have no idea what is wrong.

@Borkason
Cherokee Project member

From nilsen.s...@gmail.com on July 01, 2011 22:28:06
I just installed Ubuntu 10.04 LTS and wouldn’t you know, now Cherokee works. This is just weird.

@Borkason
Cherokee Project member

From psaod8fz...@gmail.com on December 17, 2012 19:06:49
old versions.
works for me with current versions of ubuntu and cherokee from github.

@Borkason Borkason added the t:invalid label Oct 1, 2014
@Borkason
Cherokee Project member

From December 17, 2012:

works for me with current versions of ubuntu and cherokee from github.

@Borkason Borkason closed this Oct 1, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment