www-servers/cherokee-1.2.101-r2 - cannot launch cherokee admin #936

Closed
Borkason opened this Issue Mar 24, 2013 · 3 comments

Projects

None yet

2 participants

@Borkason
Member

Original author: webmas...@colnect.com (October 25, 2012 08:17:44)

Using Gentoo with the latest Cherokee - www-servers/cherokee-1.2.101-r2

Cannot load Cherokee admin anymore. This is on at least two servers I'm using with different cherokee.conf

This used to work fine on both but as I haven't tried it since the last upgrade, this might be an issue of the most recent version.

What steps will reproduce the problem?

  1. Launch cherokee-admin
  2. Connect from a browser, password dialog pop-up up
  3. enter temporary password
  4. waiting for the admin to load but it doesn't

What is the expected output? What do you see instead?

Instead of seeing the admin interface, after a long wait I get 503
503 Service Unavailable

Cherokee web server 1.2.101 (Gentoo Linux), Port 9090

What version of the product are you using? On what operating system?
1.2.101-r2 / Gentoo

Please provide any additional information below.

​ cherokee-admin --bind=179.99.61.52 --port=9090 -x

Cherokee Web Server 1.2.101 (Aug 13 2012): Listening on port 179.99.61.52:9090,
TLS disabled, IPv6 enabled, using epoll, 4096 fds system limit, max. 2041
connections, 4 threads, 510 connections per thread, standard scheduling policy

Login:
User: admin
One-time Password: 3UOGPW1PFr6s6tSc

Web Interface:
URL: http://179.99.61.52:9090/

DEBUG: SIGUSR1 invokes the console..
SIGUSR2 prints a backtrace..
Server 1.2.101 running.. PID=4020 Port=4000
DEBUG: SIGUSR1 invokes the console..
SIGUSR2 prints a backtrace..
Server 1.2.101 running.. PID=4026 Port=4000
DEBUG: SIGUSR1 invokes the console..
SIGUSR2 prints a backtrace..
Server 1.2.101 running.. PID=4042 Port=4000
DEBUG: SIGUSR1 invokes the console..
SIGUSR2 prints a backtrace..
Server 1.2.101 running.. PID=4048 Port=4000
DEBUG: SIGUSR1 invokes the console..
SIGUSR2 prints a backtrace..
Server 1.2.101 running.. PID=4054 Port=4000
^CCherokee-admin is exiting..

This is the output using the -t option. Without the -t these lines do NOT appear:

DEBUG: SIGUSR1 invokes the console..
SIGUSR2 prints a backtrace..
Server 1.2.101 running.. PID=4020 Port=4000

I've eventually hit ctrl-c so that explains the:

^CCherokee-admin is exiting..

Bug also files for Gentoo - https://bugs.gentoo.org/show_bug.cgi?id=439590

Original issue: http://code.google.com/p/cherokee/issues/detail?id=1378

@Borkason
Member

From psaod8fz...@gmail.com on December 19, 2012 13:38:43
Hi,

can you reproduce this error with the current version from Github?
http://github.com/cherokee/webserver

Cheers

@Borkason
Member

From webmas...@colnect.com on December 21, 2012 03:09:28
Please see the bug I opened on https://bugs.gentoo.org/show_bug.cgi?id=439590 for more information. It's ipv6 related.

@Borkason
Member

From psaod8fz...@gmail.com on December 27, 2012 04:32:52
Duplicate of http://code.google.com/p/cherokee/issues/detail?id=719 (Github: #​630) as identified by the Gentoo Community (see link above).

@Borkason Borkason closed this Mar 25, 2013
@Borkason Borkason reopened this Mar 29, 2013
@skinkie skinkie closed this Mar 29, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment