Skip to content
A flashcard app for mobile devices
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
actions
assets
components
reducers
styles
utils
.gitignore
.watchmanconfig
App.js
README.md
app.json
babel.config.js
package.json
yarn.lock

README.md

Mobile Flashcards

Project home page:

The project

This is a mobile flashcard app written in React-Native. It uses expo's AsyncStorage to persist the user's data.

Installation

  1. You must have node and yarn installed.
  2. Install expo-cli using yarn global add expo-cli. If you encounter any problems during installation, please checkout the getting started guide.
  3. Clone this repo with git clone https://github.com/chidimo/Mobile-Flashcards.git
  4. Open a terminal and cd into the Mobile-Flashcards folder. You might need to run the terminal with administrative rights.
  5. Run yarn install to install the project dependencies.
  6. Run yarn start to start the project.

Links

  1. Expo documentation
  2. React native documentation

Supported platforms

This app is targeted at both Android and iOS devices but it has only been tested on Android at the time of writing.

If its tested on iOS, this space will be updated.

You can’t perform that action at this time.