build.xml does not handle 'default' platform properly. #372

Closed
EmbeddedMan opened this Issue Jul 15, 2013 · 1 comment

3 participants

@EmbeddedMan
chipKIT member

If you build MPIDE for, say, windows, and you hit ENTER in response to:
[input] Enter platform:
you will get an error like this:
D:\Projects\chipKIT32-MAX\build>ant dist
Buildfile: D:\Projects\chipKIT32-MAX\build\build.xml
[input] Enter platform:

revision-check:

dist:
[input] Enter version number: [0023]

[input] skipping input as property platform has already been set.

BUILD FAILED
D:\Projects\chipKIT32-MAX\build\build.xml:85: The following error occurred while executing this line:
Target "-dist" does not exist in the project "mpide".

@ricklon ricklon was assigned Jul 15, 2013
@rianders

Instead of running:

ant dist

Run for each platform:

ant macosx-dist
ant raspberrypi-dist
ant linux-dist
ant linux64-dist
ant windows-dist

or for build

ant macosx-build
ant raspberrypi-build
ant linux-build
ant linux64-build
ant windows-build
@ricklon ricklon closed this Aug 4, 2013
@ricklon ricklon added a commit that referenced this issue Jan 5, 2014
@ricklon ricklon removed the asking for platform. There is an alternate way to do this…
…. Resolved issue #372.

Former-commit-id: 106c852
f253aa2
@gmrozek gmrozek pushed a commit to gmrozek/chipKIT32-MAX that referenced this issue Jan 5, 2014
@ricklon ricklon removed the asking for platform. There is an alternate way to do this…
…. Resolved issue #372.

Former-commit-id: 106c852
5a794b9
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment