New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[drm] GPU HANG: ecode 0:0x87d3bffa, in compton [2243] #233

Closed
oxhak opened this Issue Sep 17, 2014 · 3 comments

Comments

Projects
None yet
3 participants
@oxhak

oxhak commented Sep 17, 2014

Hi, I have this issue, freezing my screen for a time, randomly on my C720 chromebook with archlinux.
Do you have any idea please ?

[ 7853.943556] [drm] stuck on render ring
[ 7853.945402] [drm] GPU HANG: ecode 0:0x87d3bffa, in compton [2243], reason: Ring hung, action: reset
[ 7853.945412] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 7853.945416] [drm] Please file a new bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 7853.945421] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 7853.945425] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 7853.945430] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 7855.943209] [drm] Enabling RC6 states: RC6 on, RC6p off, RC6pp off

@richardgv

This comment has been minimized.

Show comment
Hide comment
@richardgv

richardgv Sep 28, 2014

Collaborator

Sorry for the late reply, firstly.

I would recommend you to submit a report to bugs.freedesktop.org, as stated in the message. Essentially as a developer of the application layer I couldn't really help much about an issue deep in the driver stack.

There are quite a few reports (1, 2, 3, 4, 5) possibly related to the problem I found with Google.

On this side, other things I could recommend:

  1. Try to isolate the option and/or the situation that triggers the issue.
  2. Upgrading/downgrading your kernel and xf86-video-intel might help. Downgrading would be tricky on Arch, I guess, though.
  3. Using --backend xrender might be a temporary workaround?
Collaborator

richardgv commented Sep 28, 2014

Sorry for the late reply, firstly.

I would recommend you to submit a report to bugs.freedesktop.org, as stated in the message. Essentially as a developer of the application layer I couldn't really help much about an issue deep in the driver stack.

There are quite a few reports (1, 2, 3, 4, 5) possibly related to the problem I found with Google.

On this side, other things I could recommend:

  1. Try to isolate the option and/or the situation that triggers the issue.
  2. Upgrading/downgrading your kernel and xf86-video-intel might help. Downgrading would be tricky on Arch, I guess, though.
  3. Using --backend xrender might be a temporary workaround?
@oxhak

This comment has been minimized.

Show comment
Hide comment
@oxhak

oxhak Sep 28, 2014

Thank you for your reply, I do not send a bug report because there are a lot already submited.
I'm using compton with the default backend for a while, it works better.
This is not a compton issue, the issue come sometimes with opengl applications.

oxhak commented Sep 28, 2014

Thank you for your reply, I do not send a bug report because there are a lot already submited.
I'm using compton with the default backend for a while, it works better.
This is not a compton issue, the issue come sometimes with opengl applications.

@oxhak oxhak closed this Sep 28, 2014

@pit65

This comment has been minimized.

Show comment
Hide comment
@pit65

pit65 Oct 14, 2014

I've got this, after I went to 3.16 kernel from 3.12.
Intel Hasswell , xf86-video-intel - 2.99.911,Mesa - 10.2.6,Libdrm - 2.4.56,Xserver Xorg - 1.15.0

"GPU HANG: ecode 0:0x87d3bffa, in compton [13352], reason: Ring hung, action: reset"

Adding parameters to boot:

"i915.enable_rc6=1 i915.enable_fbc=1 i915.lvds_downclock=1 i915.semaphores=1"

seems working with this issue.

Update:
Above do not working correctly but freezing is less frequent so I change parameters to :

"drm.vblankoffdelay=1 i915.semaphores=0 i915.modeset=1 i915.use_mmio_flip=1 i915.enable_ppgtt=1"

After 24 houres no freezing so far :-)

pit65 commented Oct 14, 2014

I've got this, after I went to 3.16 kernel from 3.12.
Intel Hasswell , xf86-video-intel - 2.99.911,Mesa - 10.2.6,Libdrm - 2.4.56,Xserver Xorg - 1.15.0

"GPU HANG: ecode 0:0x87d3bffa, in compton [13352], reason: Ring hung, action: reset"

Adding parameters to boot:

"i915.enable_rc6=1 i915.enable_fbc=1 i915.lvds_downclock=1 i915.semaphores=1"

seems working with this issue.

Update:
Above do not working correctly but freezing is less frequent so I change parameters to :

"drm.vblankoffdelay=1 i915.semaphores=0 i915.modeset=1 i915.use_mmio_flip=1 i915.enable_ppgtt=1"

After 24 houres no freezing so far :-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment