Permalink
Browse files

Fix #17: disable syntax checking when Vim older than 7.3

  • Loading branch information...
1 parent 430c9d0 commit 168466831ffec06caacccef34db6175cf9000bcc @jimenezrick jimenezrick committed Jan 31, 2012
Showing with 6 additions and 3 deletions.
  1. +4 −1 README
  2. +2 −2 compiler/erlang.vim
View
5 README
@@ -28,7 +28,10 @@ Copy the content of the tarball to your `.vim'. Don't forget to run
`:helptags' if you are not using Pathogen.
Vimerl requires to have a recent version of Erlang installed in your
-system with `escript' in your $PATH and to use Vim 7.3 or newer.
+system with `escript' in your $PATH.
+
+With a Vim version older than 7.3 syntax checking will be disabled as
+some required features won't be available.
How to use it
View
@@ -3,9 +3,9 @@
" Author: Pawel 'kTT' Salata <rockplayer.pl@gmail.com>
" Contributors: Ricardo Catalinas Jiménez <jimenezrick@gmail.com>
" License: Vim license
-" Version: 2012/01/18
+" Version: 2012/01/31
-if exists("current_compiler")
+if exists("current_compiler") || v:version < 703
finish
else
let current_compiler = "erlang"

0 comments on commit 1684668

Please sign in to comment.