Skip to content


Subversion checkout URL

You can clone with
Download ZIP
Browse files

better installation instructions

  • Loading branch information...
commit fabc219024236e9a34a9ffbb3b0fe0b9fc20eedf 1 parent 2b2b2a9
@chorny authored
Showing with 15 additions and 6 deletions.
  1. +1 −1  Makefile.PL
  2. +14 −5 README
2  Makefile.PL
@@ -40,7 +40,7 @@ unless (
Expat must be installed prior to building XML::Parser and I can't find
it in the standard library directories. Install 'expat-devel' package with your
-OS package manager.
+OS package manager. See 'README'.
Or you can download expat from:
@@ -8,21 +8,27 @@ under the same terms as Perl itself.
This is a Perl extension interface to James Clark's XML parser, expat.
It requires at least version 5.004 of perl and it requires that you have
release 1.95.0 or greater of expat installed. You can download expat
-Install 'expat-devel' package with your OS package manager.
+Best way is to install 'expat-devel' package with your OS package manager.
Debian: expat-dev
Xubuntu 6.06: libexpat1-dev
+After that run `cpan XML::Parser`.
+You can install this module from OS package too, but CPAN has most fresh version.
+CentOS/RHEL/Fedora: perl-XML-Parser
The documentation for this extension can be found in pod format at the end
of the files and Expat/ The perldoc program, provided with
the perl distribution, can be used to view this documentation.
This was modified from the original XML::Parser created by Larry Wall.
-To configure this module, cd to the directory that contains this README file
+To manually install this module, cd to the directory that contains this README file
and type the following:
perl Makefile.PL
@@ -62,6 +68,9 @@ list, to which you can subscribe by sending mail to:
Differences from Version 2.30

0 comments on commit fabc219

Please sign in to comment.
Something went wrong with that request. Please try again.