Skip to content
Permalink
Browse files

Update all the dependencies

  • Loading branch information...
chrisbanes committed Feb 21, 2019
1 parent c4a086c commit 55335b615f8520ccdf27ca27563ee014a9b36c2d
@@ -23,20 +23,20 @@ import com.bumptech.glide.annotation.GlideExtension
import com.bumptech.glide.annotation.GlideOption
import com.bumptech.glide.annotation.GlideType
import com.bumptech.glide.load.resource.drawable.DrawableTransitionOptions
import com.bumptech.glide.request.RequestOptions
import com.bumptech.glide.request.BaseRequestOptions

@SuppressLint("CheckResult")
@GlideExtension
object GlideExtensions {
@GlideOption
@JvmStatic
fun round(options: RequestOptions, size: Int): RequestOptions {
fun round(options: BaseRequestOptions<*>, size: Int): BaseRequestOptions<*> {
return options.circleCrop().override(size)
}

@JvmStatic
@GlideType(Drawable::class)
fun saturateOnLoad(requestBuilder: RequestBuilder<Drawable>) {
requestBuilder.transition(DrawableTransitionOptions.with(SaturationTransitionFactory()))
fun saturateOnLoad(requestBuilder: RequestBuilder<Drawable>): RequestBuilder<Drawable> {
return requestBuilder.transition(DrawableTransitionOptions.with(SaturationTransitionFactory()))
}
}
@@ -49,7 +49,7 @@ buildscript {
}

plugins {
id "com.diffplug.gradle.spotless" version "3.16.0"
id "com.diffplug.gradle.spotless" version "3.18.0"
id 'com.github.ben-manes.versions' version "0.20.0"
}

@@ -21,48 +21,48 @@ object Versions {
}

object Libs {
val androidGradlePlugin = "com.android.tools.build:gradle:3.3.0"
val dexcountGradlePlugin = "com.getkeepsafe.dexcount:dexcount-gradle-plugin:0.8.5"
val playPublisherPlugin = "com.github.triplet.gradle:play-publisher:2.0.0"
val androidGradlePlugin = "com.android.tools.build:gradle:3.4.0-beta05"
val dexcountGradlePlugin = "com.getkeepsafe.dexcount:dexcount-gradle-plugin:0.8.6"
val playPublisherPlugin = "com.github.triplet.gradle:play-publisher:2.1.0"

val mvRx = "com.airbnb.android:mvrx:0.7.2"

val threeTenBp = "org.threeten:threetenbp:1.3.8"
val threeTenBpNoTzdb = "org.threeten:threetenbp:1.3.8:no-tzdb"
val threeTenAbp = "com.jakewharton.threetenabp:threetenabp:1.1.1"
val threeTenBpNoTzdb = "$threeTenBp:no-tzdb"
val threeTenAbp = "com.jakewharton.threetenabp:threetenabp:1.1.2"

val gravitySnapHelper = "com.github.rubensousa:gravitysnaphelper:2.0"

val rxLint = "nl.littlerobots.rxlint:rxlint:1.7.2"
val rxLint = "nl.littlerobots.rxlint:rxlint:1.7.3"

val timber = "com.jakewharton.timber:timber:4.7.1"

val tmdbJava = "com.uwetrottmann.tmdb2:tmdb-java:1.10.1"
val tmdbJava = "com.uwetrottmann.tmdb2:tmdb-java:2.0.1"

val appauth = "net.openid:appauth:0.7.1"

val junit = "junit:junit:4.12"
val robolectric = "org.robolectric:robolectric:4.1"
val robolectric = "org.robolectric:robolectric:4.2"
val mockitoKotlin = "com.nhaarman.mockitokotlin2:mockito-kotlin:2.1.0"

object Google {
val material = "com.google.android.material:material:1.1.0-alpha02"
val firebaseCore = "com.google.firebase:firebase-core:16.0.4"
val material = "com.google.android.material:material:1.1.0-alpha03"
val firebaseCore = "com.google.firebase:firebase-core:16.0.7"
val crashlytics = "com.crashlytics.sdk.android:crashlytics:2.9.9"
val gmsGoogleServices = "com.google.gms:google-services:4.2.0"
val fabricPlugin = "io.fabric.tools:gradle:1.27.1"
}

object Kotlin {
private const val version = "1.3.20-eap-100"
private const val version = "1.3.21"
val stdlib = "org.jetbrains.kotlin:kotlin-stdlib-jdk8:$version"
val reflect = "org.jetbrains.kotlin:kotlin-reflect:$version"
val gradlePlugin = "org.jetbrains.kotlin:kotlin-gradle-plugin:$version"
val extensions = "org.jetbrains.kotlin:kotlin-android-extensions:$version"
}

object Coroutines {
private const val version = "1.1.0"
private const val version = "1.1.1"
val core = "org.jetbrains.kotlinx:kotlinx-coroutines-core:$version"
val rx2 = "org.jetbrains.kotlinx:kotlinx-coroutines-rx2:$version"
val android = "org.jetbrains.kotlinx:kotlinx-coroutines-android:$version"
@@ -92,7 +92,7 @@ object Libs {
val archCoreTesting = "androidx.arch.core:core-testing:2.0.0"

object Paging {
private const val version = "2.0.0"
private const val version = "2.1.0"
val common = "androidx.paging:paging-common:$version"
val runtime = "androidx.paging:paging-runtime:$version"
val rxjava2 = "androidx.paging:paging-rxjava2:$version"
@@ -120,15 +120,15 @@ object Libs {
}

object Work {
private const val version = "1.0.0-beta01"
private const val version = "1.0.0-rc01"
val runtimeKtx = "android.arch.work:work-runtime-ktx:$version"
}
}

object RxJava {
val rxJava = "io.reactivex.rxjava2:rxjava:2.2.5"
val rxJava = "io.reactivex.rxjava2:rxjava:2.2.6"
val rxKotlin = "io.reactivex.rxjava2:rxkotlin:2.3.0"
val rxAndroid = "io.reactivex.rxjava2:rxandroid:2.1.0"
val rxAndroid = "io.reactivex.rxjava2:rxandroid:2.1.1"
}

object Dagger {
@@ -140,7 +140,7 @@ object Libs {
}

object Glide {
private const val version = "4.8.0"
private const val version = "4.9.0"
val glide = "com.github.bumptech.glide:glide:$version"
val compiler = "com.github.bumptech.glide:compiler:$version"
}
@@ -153,11 +153,11 @@ object Libs {
}

object OkHttp {
val loggingInterceptor = "com.squareup.okhttp3:logging-interceptor:3.12.1"
val loggingInterceptor = "com.squareup.okhttp3:logging-interceptor:3.13.1"
}

object Epoxy {
private const val version = "3.2.0"
private const val version = "3.3.0"
val epoxy = "com.airbnb.android:epoxy:$version"
val paging = "com.airbnb.android:epoxy-paging:$version"
val dataBinding = "com.airbnb.android:epoxy-databinding:$version"
@@ -1,5 +1,5 @@
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-4.10.2-bin.zip
distributionUrl=https\://services.gradle.org/distributions/gradle-5.2.1-all.zip
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists

0 comments on commit 55335b6

Please sign in to comment.
You can’t perform that action at this time.