Permalink
Browse files

Fix so formlets.cabal actually works when base 3 is not available. Ho…

…pefully this still works correctly for 6.8, 6.10, and 6.12.
  • Loading branch information...
1 parent 6ea615e commit 41e10974dc334774285d6a9db9b0803b1c16ef59 @stepcut stepcut committed Jan 6, 2010
Showing with 5 additions and 3 deletions.
  1. +5 −3 formlets.cabal
View
@@ -23,14 +23,16 @@ Flag base4
Description: Choose the even newer, even smaller, split-up base package.
Library
- Build-Depends: base >= 2 && < 4,
- haskell98,
+ Build-Depends: haskell98,
mtl,
xhtml,
applicative-extras >= 0.1.3,
bytestring
if flag(base4)
- Build-Depends: base >= 4 && < 5, syb
+ Build-Depends: base >= 4 && < 5, syb
+ else
+ Build-Depends: base >= 2 && < 4
+
Exposed-Modules: Text.Formlets
, Text.Formlets.MassInput
, Text.XHtml.Strict.Formlets

0 comments on commit 41e1097

Please sign in to comment.