Permalink
Browse files

Fix warning under older versions of JRuby that didn't provide $-w

The warning was: "warning: global variable `$-w' not initialized"
  • Loading branch information...
1 parent f0cd20a commit ea74a02b2466585357aaeb56529f332ae153ae6c @chrisk committed Dec 2, 2013
Showing with 1 addition and 1 deletion.
  1. +1 −1 test/test_helper.rb
View
@@ -76,7 +76,7 @@ def current_test_name
def current_ruby_opts
ruby_opts = []
- ruby_opts << "-w" if $-w
+ ruby_opts << "-w" if defined?($-w) && $-w
# When you start JRuby with --debug, it does this:
#

0 comments on commit ea74a02

Please sign in to comment.