Added VERSION constant to Gattica module #1

Merged
merged 1 commit into from May 18, 2011

Conversation

Projects
None yet
3 participants

john commented May 17, 2011

No description provided.

chrisle pushed a commit that referenced this pull request May 18, 2011

Chris Le
Merge pull request #1 from john/master
Added VERSION constant to Gattica module.  Thank you john!

@chrisle chrisle merged commit 40a22f5 into chrisle:master May 18, 2011

chrisle pushed a commit that referenced this pull request Jun 5, 2011

Chris Le
Merge pull request #1 from john/master
Added VERSION constant to Gattica module.  Thank you john!

where is this VERSION constant initialized? When running Gattica 0.3.4 in Ruby 1.9.2-p180 i get an error when i require 'gattica'. The problem goes away if i maually change the auth.rb file to have VERSION = '0.3.4' initialized at hte beginning of the script. But its weird that I don't get this issue on Ruby 1.8.7-p334

NameError: uninitialized constant Gattica::Auth::VERSION
from /Users/Cory/.rvm/gems/ruby-1.9.2-p180/gems/gattica-0.4.3/lib/gattica/auth.rb:14:in <class:Auth>' from /Users/Cory/.rvm/gems/ruby-1.9.2-p180/gems/gattica-0.4.3/lib/gattica/auth.rb:8:inmodule:Gattica'
from /Users/Cory/.rvm/gems/ruby-1.9.2-p180/gems/gattica-0.4.3/lib/gattica/auth.rb:4:in <top (required)>' from /Users/Cory/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:inrequire'
from /Users/Cory/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in require' from /Users/Cory/.rvm/gems/ruby-1.9.2-p180/gems/gattica-0.4.3/lib/gattica.rb:18:in<top (required)>'
from internal:lib/rubygems/custom_require:33:in require' from <internal:lib/rubygems/custom_require>:33:inrescue in require'
from internal:lib/rubygems/custom_require:29:in require' from (irb):1 from /Users/Cory/.rvm/rubies/ruby-1.9.2-p180/bin/irb:16:in

'

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment