Fix for the € symbol in entityEncode #83

Closed
vendruscolo opened this Issue Jun 11, 2012 · 2 comments

Projects

None yet

2 participants

@vendruscolo

Hi!

I think that entityEncode (and also entityDecode) use the wrong entity to encode/decode the Euro symbol.

Actually, the output of entityEncode for is ¤ which a legacy entity, as said here http://www.mail-archive.com/use-revolution@lists.runrev.com/msg109291.html — it should be €.

I made a quick "test" suite at dabblet, http://dabblet.com/gist/2910102
As you can see, ¤ is not the Euro symbol!

Thank you.

@vendruscolo vendruscolo added a commit that referenced this issue Jun 12, 2012
@vendruscolo vendruscolo Fix for issue #83.
Changed the entity of the € sign from `¤` to `€`. The Unicode
character number (0x20AC) was right.
See http://www.fileformat.info/info/unicode/char/20ac/index.htm
and http://www.mail-archive.com/use-revolution@lists.runrev.com/msg109291.html
7babc82
@chriso
Owner

Thanks. Any idea what ¤` symbol is? All references I could find say it's a "General Currency Sign"

@chriso chriso closed this Jun 12, 2012
@vendruscolo

Thanks for merging the pull request (related: sorry if I created two issues).

Quoting [Wikipedia](http://en.wikipedia.org/wiki/Currency_(typography\)):

The currency sign (¤) is a character used to denote a currency when the symbol for the particular currency is unavailable.

So it's something very generic, as far as I understand.

@shoaibkalsekar shoaibkalsekar pushed a commit that referenced this issue Dec 17, 2015
@vendruscolo vendruscolo Fix for issue #83.
Changed the entity of the € sign from `¤` to `€`. The Unicode
character number (0x20AC) was right.
See http://www.fileformat.info/info/unicode/char/20ac/index.htm
and http://www.mail-archive.com/use-revolution@lists.runrev.com/msg109291.html
f37e861
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment