Permalink
Browse files

Made it easy to optionally use RubyPython for pygments, closes #923

  • Loading branch information...
1 parent 5251313 commit 99947702257a9452a33c8af4c2c1092ad3c207d1 @imathis imathis committed Jan 14, 2013
Showing with 4 additions and 0 deletions.
  1. +4 −0 plugins/pygments_code.rb
View
@@ -3,6 +3,10 @@
require 'pygments'
require 'fileutils'
require 'digest/md5'
+begin # Make it easy for folks to use rubypython if they like
+ require 'rubypython'
+rescue LoadError # rubypython is not installed
+end
PYGMENTS_CACHE_DIR = File.expand_path('../../.pygments-cache', __FILE__)
FileUtils.mkdir_p(PYGMENTS_CACHE_DIR)

0 comments on commit 9994770

Please sign in to comment.