Skip to content


Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP


Bump multi_json for compatibility with uglifier in rails 3.1 apps #2

merged 1 commit into from

3 participants


Rails 3.1 now uses uglifier by default, which depends on multi_json 1.0.3. This gem is currently specified with multi_json ~> 0.0.5, so this results in a compatibility problem when using this gem in an rails app.

Bumping multi_json to 1.0.3 solves this, tests pass, and I haven't been able to find anything wrong in manual testing as a result of the change.


I'm using omniauth in my project and it also depends on multi_json 1.0.3

@chriswarren chriswarren merged commit b02ecf0 into from
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  assistly.gemspec
2  assistly.gemspec
@@ -16,7 +16,7 @@ do |s|
s.add_runtime_dependency('faraday', '~> 0.6.0')
s.add_runtime_dependency('faraday_middleware', '~> 0.6.3')
s.add_runtime_dependency('jruby-openssl', '~> 0.7.2') if RUBY_PLATFORM == 'java'
- s.add_runtime_dependency('multi_json', '~> 0.0.5')
+ s.add_runtime_dependency('multi_json', '~> 1.0.3')
s.add_runtime_dependency('multi_xml', '~> 0.2.0')
s.add_runtime_dependency('rash', '~> 0.3.0')
s.add_runtime_dependency('simple_oauth', '~> 0.1.4')
Something went wrong with that request. Please try again.