Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

initial commit

  • Loading branch information...
commit 19bb9d94b0281e5e68bf49f48cb1363c21586c3e 0 parents
“tombombadil” authored
3  Manifest
@@ -0,0 +1,3 @@
+Rakefile
+lib/hello_world.rb
+Manifest
12 Rakefile
@@ -0,0 +1,12 @@
+require 'rubygems'
+require 'rake'
+require 'echoe'
+
+Echoe.new('hello_world', '0.0.1') do |p|
+ p.description = "A gem that illustrates how to build a gem"
+ p.url = "http://github.com/tombombadil/hello_world"
+ p.author = "Chris Young"
+ p.email = "beesucker @nospam@ gmail.com"
+ p.ignore_pattern = ["tmp/*", "script/*"]
+ p.development_dependencies = []
+end
20 gem-public_cert.pem
@@ -0,0 +1,20 @@
+-----BEGIN CERTIFICATE-----
+MIIDNjCCAh6gAwIBAgIBADANBgkqhkiG9w0BAQUFADBBMRMwEQYDVQQDDApjaHJp
+c3lvdW5nMRUwEwYKCZImiZPyLGQBGRYFYnV6YXoxEzARBgoJkiaJk/IsZAEZFgNj
+b20wHhcNMTAwMTAxMDE0MTA2WhcNMTEwMTAxMDE0MTA2WjBBMRMwEQYDVQQDDApj
+aHJpc3lvdW5nMRUwEwYKCZImiZPyLGQBGRYFYnV6YXoxEzARBgoJkiaJk/IsZAEZ
+FgNjb20wggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIBAQDu37vOHls+p6xf
+vzazqbwWkjZhh+p6t8cMhDKzMD2O+ITMSIouKg8z2DkIDtvSnkZb3pfWEC/YkZu1
+79RahOE79mSC4IB1gLeyEMmTg1TPJkNxIuoG632Sp09j2Eg8EUW1EToSFsh+gIwz
+FcCBFWQ1yq0IgfQZ9+RM8a8Ei6uKfQXmm4wK6vZT5Lxp8Dv0nELoO1dkYV1WXkGh
+AAFhUMX2Y9tp0x2XZztO2Z+AUL4GYD1PyU2Afh7qp/qQJZMVS0YJjulB2bnW2yn/
+7vlBadeBo3Ohp1J+OJuMUtmnuOAcKo+4cbj3HT4xTyuUa+V3izENJKX3qWCTk1D+
+mU8TzNlzAgMBAAGjOTA3MAkGA1UdEwQCMAAwCwYDVR0PBAQDAgSwMB0GA1UdDgQW
+BBSTLbhEokEPfV+oVZKmXVmGucmgljANBgkqhkiG9w0BAQUFAAOCAQEAQqRkDRig
+aHqxsoqnJjG9FgZCIidnYhLNj7c3hXy8OQKJMZYau5VSDZb8dS4hC+jxQuyXiRJr
+z5E16Gbqkb2fRC/YU63FnfIg2ce7PlGTp8yw0Xypn3QBYywDAWWJS4TdguikEDOM
+e8IOmSKyOVJ7Zn6DIC0qyVtdcacXuKXWqqYQaWNwFwlaSlud5mQlyB77lcj5E5Lc
+2mBFwT18jFQay2vOU/lgBDXBQ/VmrgL22gnhLL2nSf++CHM8miqa39Jk2MPaTbMs
+tMtvELogNijvQYORkxU83coIjJ0bIsxgbjeBoFEcWCKkq/e8uSLULcJR4nULhvR3
+bIN1xy1IiuNcvw==
+-----END CERTIFICATE-----
BIN  hello_world-0.0.1.gem
Binary file not shown
32 hello_world.gemspec
@@ -0,0 +1,32 @@
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = %q{hello_world}
+ s.version = "0.0.1"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 1.2") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Chris Young"]
+ s.date = %q{2010-01-02}
+ s.description = %q{A gem that illustrates how to build a gem}
+ s.email = %q{beesucker @nospam@ gmail.com}
+ s.extra_rdoc_files = ["lib/hello_world.rb"]
+ s.files = ["Rakefile", "lib/hello_world.rb", "Manifest", "hello_world.gemspec"]
+ s.homepage = %q{http://github.com/tombombadil/hello_world}
+ s.rdoc_options = ["--line-numbers", "--inline-source", "--title", "Hello_world"]
+ s.require_paths = ["lib"]
+ s.rubyforge_project = %q{hello_world}
+ s.rubygems_version = %q{1.3.5}
+ s.summary = %q{A gem that illustrates how to build a gem}
+ s.signing_key = '/Volumes/Secure/Certificates/gem-private_key.pem'
+ s.cert_chain = ['gem-public_cert.pem']
+
+ if s.respond_to? :specification_version then
+ current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ else
+ end
+ else
+ end
+end
5 lib/hello_world.rb
@@ -0,0 +1,5 @@
+module HelloWorld
+ def self.say_hello
+ puts 'hello world'
+ end
+end
BIN  pkg/hello_world-0.0.1.gem
Binary file not shown
BIN  pkg/hello_world-0.0.1.tar.gz
Binary file not shown
3  pkg/hello_world-0.0.1/Manifest
@@ -0,0 +1,3 @@
+Rakefile
+lib/hello_world.rb
+Manifest
12 pkg/hello_world-0.0.1/Rakefile
@@ -0,0 +1,12 @@
+require 'rubygems'
+require 'rake'
+require 'echoe'
+
+Echoe.new('hello_world', '0.0.1') do |p|
+ p.description = "A gem that illustrates how to build a gem"
+ p.url = "http://github.com/tombombadil/hello_world"
+ p.author = "Chris Young"
+ p.email = "beesucker @nospam@ gmail.com"
+ p.ignore_pattern = ["tmp/*", "script/*"]
+ p.development_dependencies = []
+end
30 pkg/hello_world-0.0.1/hello_world.gemspec
@@ -0,0 +1,30 @@
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = %q{hello_world}
+ s.version = "0.0.1"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 1.2") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Chris Young"]
+ s.date = %q{2010-01-02}
+ s.description = %q{A gem that illustrates how to build a gem}
+ s.email = %q{beesucker @nospam@ gmail.com}
+ s.extra_rdoc_files = ["lib/hello_world.rb"]
+ s.files = ["Rakefile", "lib/hello_world.rb", "Manifest", "hello_world.gemspec"]
+ s.homepage = %q{http://github.com/tombombadil/hello_world}
+ s.rdoc_options = ["--line-numbers", "--inline-source", "--title", "Hello_world"]
+ s.require_paths = ["lib"]
+ s.rubyforge_project = %q{hello_world}
+ s.rubygems_version = %q{1.3.5}
+ s.summary = %q{A gem that illustrates how to build a gem}
+
+ if s.respond_to? :specification_version then
+ current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ else
+ end
+ else
+ end
+end
5 pkg/hello_world-0.0.1/lib/hello_world.rb
@@ -0,0 +1,5 @@
+module HelloWorld
+ def self.say_hello
+ puts 'hello world'
+ end
+end
Please sign in to comment.
Something went wrong with that request. Please try again.