Skip to content
Commits on Jan 19, 2012
  1. v1.20120119

    committed Jan 19, 2012
        - fixed for Perl 5.15.5 and later (ANDK and sprout)
  2. Made work with $^H encapsulation of Perl 5.15.5.

    committed Jan 19, 2012
    Reported by Andreas König, patch from Father Chrysostomos.
Commits on Jan 6, 2012
  1. v1.20120106

    committed Jan 5, 2012
        - loaded IO::File/IO::Handle to allow methods on lexical filehandles
        - added unimporting
        - removed use of autodie; moved it to a distribution prerequisite
        - enabled unicode_strings by default when your Perl supports it
Commits on Jan 5, 2012
  1. Made unicode_strings on by default when available.

    committed Jan 5, 2012
    This *only* applies to bare 'use Modern::Perl;'.
  2. Made year imports check Perl 5 versions.

    committed Jan 5, 2012
    This should help older CPAN testers pass these tests.
  3. Removed autodie from runtime dependency.

    committed Jan 5, 2012
    Moved autodie to prereqs. This means it's available if you want to load it, but
    you don't pay for it simply by using Modern::Perl.
  4. Added unimporting, with tests.

    committed Jan 5, 2012
    Note that this applies only to pragmas.
  5. Added implicit loading of IO::File and IO::Handle.

    committed Jan 5, 2012
    This of course has little effect on 5.14, but Modern::Perl should work back to
    5.10 for now.
  6. v1.20120105

    committed Jan 4, 2012
        - migrated to Dist::Zilla
        - added autodie dependency/import
  7. Improved .gitignore.

    committed Jan 4, 2012
  8. Improved test handling.

    committed Jan 4, 2012
  9. Migrated to dzil.

    committed Jan 4, 2012
  10. Updated with Git import.

    committed Jan 4, 2012
  11. Minor improvements:

    committed Feb 17, 2009
        - removed duplicate use lines (Damien Learns Perl)
        - fixed (hopefully) v-string warnings (Damien, David Moreno)
        - enabled C3 MRO (Evan Carroll)
  12. Documentation updates:

    committed Jan 26, 2009
        - fixed a typo reported by Vasily Chekalkin
        - added caveats to the documentation per bug report from Ben Hengst
  13. initial import of Modern-Perl 1.00 from CPAN

    committed Jan 26, 2009
    git-cpan-module:   Modern-Perl
    git-cpan-version:  1.00
    git-cpan-authorid: CHROMATIC
    git-cpan-file:     authors/id/C/CH/CHROMATIC/Modern-Perl-1.00.tar.gz
Something went wrong with that request. Please try again.