Permalink
Browse files

Dropping support to Django 1.2

  • Loading branch information...
1 parent 5f38229 commit f34301dd70d640c6dc117d3ec7381bdc01d87b70 @chronossc committed Oct 20, 2012
Showing with 9 additions and 6 deletions.
  1. +1 −2 .travis.yml
  2. +4 −1 README.markdown
  3. +1 −0 requirements.txt
  4. +1 −1 runtests.sh
  5. +2 −2 setup.py
View
@@ -4,8 +4,7 @@ python:
- "2.7"
env:
- DJANGO=1.4.2
- # - DJANGO=1.3.4
- # - DJANGO=1.2.7
+ - DJANGO=1.3.4
install:
- pip install -q Django==$DJANGO --use-mirrors
- pip install -q . --use-mirrors
View
@@ -6,7 +6,10 @@
It works as a pluggable middleware that add a breadcrumbs callable/iterable in your request object, allowing you to set breadcrumbs (one or more) in each view accepting objects, lists or tuples added from request.breadcrumbs and is iterable, easy to use in templates providing a object with name and url attributes.
-*Note: For Django 1.x, check for tag 1.0 and patches :)*
+# Django versions
+
+Breadcrumbs support 1.3.x and 1.4.x releases of Django.
+Django 1.2.x support was dropped in django-breadcrumbs-1.1.3.
#1 - Install django-breadcrumbs
View
@@ -0,0 +1 @@
+Django>=1.3.4
View
@@ -1,7 +1,7 @@
#!/bin/bash
echo "This is a helper script to test breadcrumbs against many environ versions."
-echo "This script test against Django 1.2x, 1.3.x and 1.4.x using sqlite. It depends of pip."
+echo "This script test against Django 1.3.x and 1.4.x using sqlite. It depends of pip."
OLD_DJANGO="$(pip freeze | grep Django)"
View
@@ -1,7 +1,7 @@
from setuptools import setup, find_packages
setup(
name="django-breadcrumbs",
- version="1.1.2-p1",
+ version="1.1.3",
packages=find_packages(exclude=('breadcrumbs_sample*', 'sample_d14*')),
author="Felipe 'chronos' Prenholato",
author_email="philipe.rp@gmail.com",
@@ -27,5 +27,5 @@
"Operating System :: OS Independent",
"Programming Language :: Python",
],
- install_requires=["Django>=1.2.7"],
+ install_requires=["Django>=1.3.4"],
)

0 comments on commit f34301d

Please sign in to comment.