Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

bump version to 3.1.0

update finagle/util dependency to 6.3.0
  • Loading branch information...
commit eb28fd9fcb8cb24e7fa370817a25a1e532ab1b9c 1 parent 1617518
@chunyan authored
View
8 CHANGELOG
@@ -1,3 +1,11 @@
+3.1.0 - 04/11/2013
+===============================================================================
+* Dependency changes: now on util/finagle 6.3.0
+* demo project now shows how to construct finagle server and client using
+generated code
+* --ostrich flag implies --finagle flag
+
+
3.0.9 - 03/27/2013
===============================================================================
* Remove "provided" scope of finagle in scrooge-runtime. So it brings Finagle
View
2  pom.xml
@@ -4,7 +4,7 @@
<groupId>com.twitter</groupId>
<artifactId>scrooge</artifactId>
<packaging>pom</packaging>
- <version>3.1.0-SNAPSHOT</version>
+ <version>3.1.0</version>
<name>scrooge</name>
<url>http://github.com/twitter/scrooge</url>
<description>A Thrift generator for Scala</description>
View
14 scrooge-generator/pom.xml
@@ -8,7 +8,7 @@
<parent>
<groupId>com.twitter</groupId>
<artifactId>scrooge</artifactId>
- <version>3.1.0-SNAPSHOT</version>
+ <version>3.1.0</version>
</parent>
<properties>
<git.dir>${project.basedir}/../../.git</git.dir>
@@ -25,7 +25,7 @@
<dependency>
<groupId>com.twitter</groupId>
<artifactId>scrooge-runtime</artifactId>
- <version>3.1.0-SNAPSHOT</version>
+ <version>3.1.0</version>
<scope>test</scope>
</dependency>
<!-- library dependencies -->
@@ -42,12 +42,12 @@
<dependency>
<groupId>com.twitter</groupId>
<artifactId>util-core_2.9.2</artifactId>
- <version>6.1.0</version>
+ <version>6.3.0</version>
</dependency>
<dependency>
<groupId>com.twitter</groupId>
<artifactId>util-codec_2.9.2</artifactId>
- <version>6.1.0</version>
+ <version>6.3.0</version>
</dependency>
<dependency>
<groupId>junit</groupId>
@@ -100,19 +100,19 @@
<dependency>
<groupId>com.twitter</groupId>
<artifactId>finagle-core_2.9.2</artifactId>
- <version>6.1.0</version>
+ <version>6.3.0</version>
<scope>test</scope>
</dependency>
<dependency>
<groupId>com.twitter</groupId>
<artifactId>finagle-thrift_2.9.2</artifactId>
- <version>6.1.0</version>
+ <version>6.3.0</version>
<scope>test</scope>
</dependency>
<dependency>
<groupId>com.twitter</groupId>
<artifactId>finagle-ostrich4_2.9.2</artifactId>
- <version>6.1.0</version>
+ <version>6.3.0</version>
<scope>test</scope>
</dependency>
</dependencies>
View
6 scrooge-maven-plugin/pom.xml
@@ -10,14 +10,14 @@
<parent>
<groupId>com.twitter</groupId>
<artifactId>scrooge</artifactId>
- <version>3.1.0-SNAPSHOT</version>
+ <version>3.1.0</version>
</parent>
<dependencyManagement>
<dependencies>
<dependency>
<groupId>com.twitter</groupId>
<artifactId>util-core_2.9.2</artifactId>
- <version>6.1.0</version>
+ <version>6.3.0</version>
</dependency>
</dependencies>
</dependencyManagement>
@@ -124,7 +124,7 @@
<dependency>
<groupId>com.twitter</groupId>
<artifactId>scrooge-generator</artifactId>
- <version>3.1.0-SNAPSHOT</version>
+ <version>3.1.0</version>
</dependency>
</dependencies>
<reporting>
View
8 scrooge-runtime/pom.xml
@@ -7,7 +7,7 @@
<parent>
<groupId>com.twitter</groupId>
<artifactId>scrooge</artifactId>
- <version>3.1.0-SNAPSHOT</version>
+ <version>3.1.0</version>
</parent>
<properties>
<git.dir>${project.basedir}/../../.git</git.dir>
@@ -29,17 +29,17 @@
<dependency>
<groupId>com.twitter</groupId>
<artifactId>util-codec_2.9.2</artifactId>
- <version>6.2.4</version>
+ <version>6.3.0</version>
</dependency>
<dependency>
<groupId>com.twitter</groupId>
<artifactId>finagle-core_2.9.2</artifactId>
- <version>6.2.1</version>
+ <version>6.3.0</version>
</dependency>
<dependency>
<groupId>com.twitter</groupId>
<artifactId>finagle-thrift_2.9.2</artifactId>
- <version>6.2.1</version>
+ <version>6.3.0</version>
</dependency>
</dependencies>
<build>
Please sign in to comment.
Something went wrong with that request. Please try again.