broken with ruby 1.9.2? #44

Closed
solars opened this Issue Oct 20, 2011 · 3 comments

Projects

None yet

3 participants

@solars

Hi, I also have to add an issue on 1.9.2 after migrating an app to it :(

https://gist.github.com/60e8839b49133f64d79e

running rake all under ruby-1.9.2 having this in my Rakefile:

require 'bundler'
Bundler::GemHelper.install_tasks

Bundler.setup
require 'rake'
require 'rspec/core/rake_task'
require 'ci/reporter/rake/rspec'

RSpec::Core::RakeTask.new(:spec) do |s|
s.rspec_opts = "--format=#{ENV['RSPEC_FORMAT'] || 'nested'} --colour"
end

task :default => :spec

RSpec::Core::RakeTask.new(:all => ["ci:setup:rspec"]) do |t|
t.pattern = '*/_spec.rb'
end

@solars

is there a solution to this?
rspec spec works fine

@rsutphin

From your gist, it looks like you're running into #41, which is not specific to 1.9.2. It's a problem with RSpec 2.7.0.

@nicksieger
ci-reporter member

closing as a duplicate of #41.

@nicksieger nicksieger closed this Jan 28, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment