Failure with shoulda test suites #9

Closed
ashb opened this Issue Jul 22, 2010 · 5 comments

Comments

Projects
None yet
5 participants

ashb commented Jul 22, 2010

Following the instructions to the best of my ability (I've only just started working with ruby): i get no test/reports created. Setting CI_REPORTS seems to have no effect either

My Rakefile is

require File.expand_path('../config/application', __FILE__)
require 'rake'

Rails::Application.load_tasks

require 'rubygems'
gem 'ci_reporter'
require 'ci/reporter/rake/test_unit'

My understanding is shoulda is Test::Unit compatible

(Note that the instructions refer to a rails plugin but I can't find that anywhere)

I think I have started seeing the same problem.

It still prints rm -rf test/reports so the ci:setup:* step is still run, but no XML is ever generated, the directory isn't even created! So CI stopped working :-/

I remember someone in my team spoke about updating the shoulda gem. We are now using 2.10.3. Perhaps there is a specific version where it breaks...

tobsch commented Aug 24, 2010

Any progress on this? I just wanted to give ci_reporter a try - no chance.

What version of Ruby are you using? It doesn't work with Ruby 1.9 as far as I can tell.

@shepmaster shepmaster added the test-unit label Jun 3, 2014

Owner

shepmaster commented Jun 12, 2014

We are in the process of cleaning out old issues. Specifically, the
next version of CI::Reporter is only going to support Test::Unit
bundled with the latest version of Ruby 1.9.3, 2.0, and 2.1. If this
issue still applies to these versions, please let us know, otherwise
we're going to close this issue to focus on current problems. Thanks
for your report!

Owner

shepmaster commented Jul 22, 2014

Closing due to inactivity.

@shepmaster shepmaster closed this Jul 22, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment