The extensible select component built for ember.
Switch branches/tags
Clone or download
Latest commit 4cb050d Nov 15, 2018
Permalink
Failed to load latest commit information.
addon-test-support Remove console-log from test helper (#1119) May 24, 2018
addon Add highlightOnHoverEnabled to be used in options.js (#1166) Oct 5, 2018
app allow negative dropdown-margin values (#991) Oct 14, 2017
blueprints/ember-power-select Add blueprint + tests Jan 20, 2017
config Update to ember-cli 3.4 (#1149) Sep 6, 2018
fastboot-tests Use fastboot test helpers Feb 14, 2016
node-tests/blueprints Add blueprint + tests Jan 20, 2017
test-support/helpers Deprecate /test-support folder (#1026) Nov 23, 2017
tests Fix typo Nov 15, 2018
vendor Released v1.9.10 Oct 15, 2017
.bowerrc Initial Commit from Ember CLI v1.13.8 Sep 24, 2015
.editorconfig Upgrade to 2.8 family Sep 15, 2016
.ember-cli Initial Commit from Ember CLI v1.13.8 Sep 24, 2015
.eslintignore Update to ember-cli 3.4 (#1149) Sep 6, 2018
.eslintrc.js Update to ember-cli 3.4 (#1149) Sep 6, 2018
.gitignore Update to ember-cli 3.2 (#1132) Jul 7, 2018
.netlify Configure netlify and disable mirage in prod Nov 10, 2017
.npmignore Update to ember-cli 3.4 (#1149) Sep 6, 2018
.template-lintrc.js Update to ember-cli 3.4 (#1149) Sep 6, 2018
.tern-port Add ember-cli-template-lint (#506) May 15, 2016
.travis.yml Update to ember-cli 3.4 (#1149) Sep 6, 2018
.watchmanconfig Update ember-cli to 1.13.10 Nov 12, 2015
CHANGELOG.md v2.0.9 Oct 5, 2018
CONTRIBUTING.md Improve documentation (#1177) Nov 15, 2018
LICENSE.md Update to latest 2.11 beta Jan 21, 2017
README.md 2.X is not in beta Aug 11, 2018
compile-css.js Update addon to 3.1 (#1088) Apr 15, 2018
deploy.sh Configure netlify and disable mirage in prod Nov 10, 2017
ember-cli-build.js Pre-render docs site at build time (#1102) Apr 25, 2018
index.js Update to ember-cli 3.4 (#1149) Sep 6, 2018
jsconfig.json Adapt to a11y changes in ember-basic-dropdown Feb 10, 2017
package.json v2.0.9 Oct 5, 2018
run-fastboot-tests.js Update addon to 3.1 (#1088) Apr 15, 2018
testem.js Update to ember-cli 3.2 (#1132) Jul 7, 2018
yarn.lock Update ember-data to 3.4 (#1150) Sep 6, 2018

README.md

Build Status Ember Observer Score Code Climate npm version dependencies

Ember-Power-Select

Ember Power Select is a select component written in Ember with a focus in flexibility and extensibility.

It is designed to work well with the way we build Ember apps, so it plays nicely with promises, ember-concurrency's tasks, ember-data collections and follows idiomatic patterns.

Installation

Ember Power Select 1.X works in Ember 2.3.1+, beta and canary with no deprecations whatsoever. Any deprecation will be considered a bug.

As any other ember-cli addon, run:

ember install ember-power-select

Ember Power Select 2.X requires Ember 2.10.0+.

Features overview

Ember Power Select wants to be as agnostic as possible about how you're going to use it, but it still provides some default implementations that will match 95% of your needs, and exposes actions to customize the other 5% of usages.

Features include:

  • Single select
  • Multiple select
  • HTML inside the options or the trigger.
  • Filter options sanitizing diacritics.
  • Custom matchers.
  • Asynchonous searches.
  • Theming
  • Fully promise-aware, with loading states.
  • Compatible with ember-concurrency task cancellation.
  • Compatibility with ember-data's ArrayProxies
  • Groups (with not deep limit), placeholders...
  • Clear the selection
  • Disable the component or individual options
  • CSS animations and transitions
  • ... and anything else you want. Just replace parts of the selects with your own components.

Usage

Check the full documentation with live examples at www.ember-power-select.com and please open an issue if something doesn't work or is not clear enough.

Good docs are important :)

Extensions

Ember-power-select's focus on flexibility enables the community to build richer and more tailor made components on top of it, focused in solving one particular problem, using composition.

Check the addons section to see some and if you create one that you want to open source open a PR to include it in the list.

Browser support

This component was just tested it in modern browsers but there is no technical reason it wouldn't work in IE9+. If you find any problem please file an issue.

Testing

In testing it requires phantomjs 2.0+. This component also provides some convenient test helpers to interact with the component in acceptance tests.

Contributing

Any contribution is welcome. Please read our guidelines. However, if your contribution involves adding a new feature, please open an issue before to share your plan and agree the details of the feature before starting implementing it.

Troubleshooting

If something doesn't work visit the Troubleshooting section of the docs first and if your problem persist open an issue, specify the version of the component, Ember and browser.