Skip to content
Permalink
Browse files

Drop Python 2.6 and 3.2 support; Issue #152

  • Loading branch information...
spaceone committed Jul 6, 2016
1 parent 25e78c0 commit f62fcd2548a493093c82ade4c1ca2d19f499e57e
Showing with 10 additions and 12 deletions.
  1. +1 −1 .github/ISSUE_TEMPLATE.md
  2. +0 −3 .travis.yml
  3. +1 −1 README.md
  4. +1 −1 README.rst
  5. +1 −1 docs/source/dev/environment.rst
  6. +1 −1 docs/source/faq.rst
  7. +2 −2 docs/source/start/requirements.rst
  8. +3 −2 setup.py
@@ -13,7 +13,7 @@ the problem ourselves.
### Environment and Platform

- OS: Linux, Windows or BSD / OS X?
- Python: 2.6, 2.7, 3.5, PyPy?
- Python: 2.7, 3.5, PyPy?
- circuits: 3.2? Something older?

----
@@ -4,9 +4,6 @@ language: python

matrix:
include:
- os: linux
python: 2.6
env: TOXENV=py26
- os: linux
python: 2.7
env: TOXENV=py27
@@ -43,7 +43,7 @@ Supported Platforms
===================

- Linux, FreeBSD, Mac OS X, Windows
- Python 2.6, 2.7, 3.2, 3.3, 3.4
- Python 2.7, 3.3, 3.4, 3.5
- pypy 2.0, 2.1, 2.2

Installation
@@ -78,7 +78,7 @@ Supported Platforms
-------------------

- Linux, FreeBSD, Mac OS X, Windows
- Python 2.6, 2.7, 3.2, 3.3, 3.4
- Python 2.7, 3.3, 3.4, 3.5
- pypy 2.0, 2.1, 2.2


@@ -13,7 +13,7 @@ This is the recommended way to setup a development enviornment
for developing with or on circuits.

.. note:: This document *assumes* you already have a working `Python`_
environment with a minimum `Python`_ version of 2.6 as well
environment with a minimum `Python`_ version of 2.7 or 3.3 as well
as `pip`_ already installed.


@@ -42,7 +42,7 @@ General
... What platforms does circuits support?
circuits currently supports Linux, FreeBSD, OSX and Windows and is
currently continually tested against Linux and Windows against Python
versions 2.6, 2.7, 3.1 and 3.2
versions 2.7, 3.3, 3.4 and 3.5

... Can circuits be used for concurrent or distributed programming?
Yes. We also have plans to build more distributed components into circuits
@@ -6,11 +6,11 @@ Requirements and Dependencies


- circuits has no **required** dependencies beyond the `Python Standard Library`_.
- Python: >= 2.6 or pypy >= 2.0
- Python: >= 2.7 or pypy >= 2.0

:Supported Platforms: Linux, FreeBSD, Mac OS X, Windows

:Supported Python Versions: 2.6, 2.7, 3.2, 3.3
:Supported Python Versions: 2.7, 3.3, 3.4, 3.5

:Supported pypy Versions: 2.0

@@ -43,11 +43,12 @@ def read_file(filename):
"Operating System :: POSIX :: Linux",
"Operating System :: MacOS :: MacOS X",
"Operating System :: Microsoft :: Windows",
"Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3.1",
"Programming Language :: Python :: 3.2",
"Programming Language :: Python :: 3.3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Adaptive Technologies",

0 comments on commit f62fcd2

Please sign in to comment.
You can’t perform that action at this time.