New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Citra-qt no longer loading games on MacOS 10.13 #4515

Open
MojitoFan opened this Issue Dec 16, 2018 · 11 comments

Comments

Projects
None yet
10 participants
@MojitoFan
Copy link

MojitoFan commented Dec 16, 2018

Hello,
From nightly build 1149 d2003da and Canary build 1113 8b4b40d onwards (as I found out by testing previous builds) Citra would no longer load games, instead returning this message

Your GPU may not support OpenGL 3.3, or you do not have the latest graphics driver

My GPU does have support for OpenGL 4.1 and in fact Citra has worked fairly well with games on my system before these updates.
I could not find any significant changes in the changelog that might cause Citra to suddenly stop loading games. Here's the logs from the latest working versions and the latest releases as of this post for comparison.
citra_log canary 1112 (latest working).txt
citra_log canary 1113.txt
citra_log canary 1131.txt
citra_log nightly 1144 (latest working).txt
citra_log nightly 1149.txt
citra_log nightly 1154.txt

This is not an isolated case and I've seen multiple similar reports, but I saw nothing about those on this rep so I'm putting this up here.

  • Operating System: MacOS 10.13.6
  • CPU: 2,7 GHz Intel i5
  • GPU: AMD Radeon HD 6770M
@wwylele

This comment has been minimized.

Copy link
Member

wwylele commented Dec 16, 2018

If nightly build 1148 still works, then the cause must be out of our scope because the change from 1148 to 1149 is pretty unrelated and trivial af. It might be that travis CI and/or MacOS silently updated something. Could anyone compile citra locally and test if it still works?

@JNaftali

This comment has been minimized.

Copy link

JNaftali commented Dec 24, 2018

I tried with both the most recent nightly (1161) and also with build 1148 - neither worked for me, although this if my first time installing Citra so I can't guarantee this is the same issue.

I tried to build from source but it failed partway through. If there's anything I can do to help move this issue forward lemme know!

@farmerpaul

This comment has been minimized.

Copy link

farmerpaul commented Dec 24, 2018

I too am trying Citra for the first time, and I had exactly the same experience. The latest available build fails with this OpenGL 3.3 error, although I've got a relatively modern Mac. I haven't tried build 1148 since there's no MacOS version available, but the next most recent MacOS nightly build is 1144, and that one works for me.

@smallqiang

This comment has been minimized.

Copy link

smallqiang commented Dec 25, 2018

I downloaded the latest Citra. It's showed "Your GPU may not support OpenGL 3.3, or you do not have the latest graphics driver". My iMac is the relatively modern. Please quickly to resolve it.

@JasonDeJonge

This comment has been minimized.

Copy link

JasonDeJonge commented Dec 28, 2018

I have same issue. Downloaded update and now my games stopped working due to OpenGL 3.3 support. My drivers support 3.3... this is why I always prefer off the shelf because it actually works

FYI I've tried building locally with few different versions and nothing works unfortunately. Probably hard to predict that it would break, not blaming devs or anything. Just saying if I was paying and money was going toward a lovely testing/deployment strategy then probably issue would be caught before hand.

@Craig-Janssen

This comment has been minimized.

Copy link

Craig-Janssen commented Jan 20, 2019

I had the same problem on OS X 10.13.6, running the latest nightly build. Rolling back to nightly 1144 fixes the problem.

@androidfans

This comment has been minimized.

Copy link

androidfans commented Jan 26, 2019

10.13.6 meet this problem too

@jjant

This comment has been minimized.

Copy link

jjant commented Jan 28, 2019

Same problem in 10.13.2

@Sparen

This comment has been minimized.

Copy link

Sparen commented Feb 2, 2019

Does this issue have a workaround by reverting to a previous build, or have previous builds been retroactively broken?

@MojitoFan MojitoFan changed the title Citra-qt no longer loading games on MacOS Citra-qt no longer loading games on MacOS 10.13 Feb 2, 2019

@MojitoFan

This comment has been minimized.

Copy link
Author

MojitoFan commented Feb 2, 2019

As far as I know only the Qt frontend is broken in High Sierra, Citra itself does play games fine when launched from terminal commands.

@Sparen

This comment has been minimized.

Copy link

Sparen commented Feb 2, 2019

I'm able to run on Canary 1112 for now. Thanks for the heads up.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment