Permalink
Browse files

depend on spree 1.1.0 and above, remove attachment size migration and…

… remove copy_migrations from install generator
  • Loading branch information...
1 parent d74f141 commit 429af81c60ee1e6f530da24f9f91125fa3571487 @citrus committed May 1, 2012
@@ -1,9 +0,0 @@
-class AddAttachmentFileSizeToAssets < ActiveRecord::Migration
- def self.up
- add_column :spree_assets, :attachment_file_size, :integer unless column_exists?(:spree_assets, :attachment_file_size)
- end
-
- def self.down
- remove_column :spree_assets, :attachment_file_size if column_exists?(:spree_assets, :attachment_file_size)
- end
-end
@@ -7,10 +7,6 @@ class InstallGenerator < Rails::Generators::Base
class_option :add_stylesheets, :type => :boolean, :default => true, :banner => 'Append spree_essentials to admin/all.css'
class_option :add_javascripts, :type => :boolean, :default => true, :banner => 'Append spree_essentials to admin/all.js'
- def copy_migrations
- rake "spree_essentials:install:migrations"
- end
-
def append_stylesheets
return unless options[:add_stylesheets]
gsub_file "app/assets/stylesheets/admin/all.css", "*/", "*= require admin/spree_essentials\n*/"
@@ -18,7 +18,7 @@ Gem::Specification.new do |s|
s.require_paths = ["lib"]
- s.add_runtime_dependency('spree_core', '~> 1.1.0.rc1')
+ s.add_runtime_dependency('spree_core', '~> 1.1.0')
s.add_runtime_dependency('rdiscount', '~> 1.6.8')
s.add_development_dependency('shoulda', '~> 3.0.0')

0 comments on commit 429af81

Please sign in to comment.