Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot install 2.9: requirements.txt is missing (pip) #5726

Closed
frafra opened this issue Nov 8, 2020 · 0 comments · Fixed by #5738
Closed

Cannot install 2.9: requirements.txt is missing (pip) #5726

frafra opened this issue Nov 8, 2020 · 0 comments · Fixed by #5738
Assignees

Comments

@frafra
Copy link
Contributor

frafra commented Nov 8, 2020

CKAN version
2.9.1

Describe the bug

pip install ckan
Collecting ckan
  Downloading ckan-2.9.1.tar.gz (8.5 MB)
     |████████████████████████████████| 8.5 MB 4.1 MB/s 
  Installing build dependencies ... done
  Getting requirements to build wheel ... error
  ERROR: Command errored out with exit status 1:
   command: /home/frafra/.cache/pypoetry/virtualenvs/ckan-tools-Wy9USEi_-py3.8/bin/python /home/frafra/.cache/pypoetry/virtualenvs/ckan-tools-Wy9USEi_-py3.8/lib/python3.8/site-packages/pip/_vendor/pep517/_in_process.py get_requires_for_build_wheel /tmp/tmpce1270de
       cwd: /tmp/pip-install-1spe5bql/ckan
  Complete output (18 lines):
  Traceback (most recent call last):
    File "/home/frafra/.cache/pypoetry/virtualenvs/ckan-tools-Wy9USEi_-py3.8/lib/python3.8/site-packages/pip/_vendor/pep517/_in_process.py", line 280, in <module>
      main()
    File "/home/frafra/.cache/pypoetry/virtualenvs/ckan-tools-Wy9USEi_-py3.8/lib/python3.8/site-packages/pip/_vendor/pep517/_in_process.py", line 263, in main
      json_out['return_val'] = hook(**hook_input['kwargs'])
    File "/home/frafra/.cache/pypoetry/virtualenvs/ckan-tools-Wy9USEi_-py3.8/lib/python3.8/site-packages/pip/_vendor/pep517/_in_process.py", line 114, in get_requires_for_build_wheel
      return hook(config_settings)
    File "/tmp/pip-build-env-gf0u_res/overlay/lib/python3.8/site-packages/setuptools/build_meta.py", line 149, in get_requires_for_build_wheel
      return self._get_build_requires(
    File "/tmp/pip-build-env-gf0u_res/overlay/lib/python3.8/site-packages/setuptools/build_meta.py", line 130, in _get_build_requires
      self.run_setup()
    File "/tmp/pip-build-env-gf0u_res/overlay/lib/python3.8/site-packages/setuptools/build_meta.py", line 253, in run_setup
      super(_BuildMetaLegacyBackend,
    File "/tmp/pip-build-env-gf0u_res/overlay/lib/python3.8/site-packages/setuptools/build_meta.py", line 145, in run_setup
      exec(compile(code, __file__, 'exec'), locals())
    File "setup.py", line 204, in <module>
      with open(os.path.join(HERE, filepath), 'r') as f:
  FileNotFoundError: [Errno 2] No such file or directory: 'requirements.txt'
  ----------------------------------------
ERROR: Command errored out with exit status 1: /home/frafra/.cache/pypoetry/virtualenvs/ckan-tools-Wy9USEi_-py3.8/bin/python /home/frafra/.cache/pypoetry/virtualenvs/ckan-tools-Wy9USEi_-py3.8/lib/python3.8/site-packages/pip/_vendor/pep517/_in_process.py get_requires_for_build_wheel /tmp/tmpce1270de Check the logs for full command output.
WARNING: You are using pip version 20.2.2; however, version 20.2.4 is available.
You should consider upgrading via the '/home/frafra/.cache/pypoetry/virtualenvs/ckan-tools-Wy9USEi_-py3.8/bin/python -m pip install --upgrade pip' command.

Additional details
It happens with CKAN 2.9.0 and poetry too.

@amercader amercader self-assigned this Nov 10, 2020
amercader added a commit that referenced this issue Nov 10, 2020
Fixes #5726

This was missing from #5408, which allows installing the requirements
using pip, but didn't include the actual requirement files in the
published package, causing an exception when running `pip install ckan`
smotornyuk added a commit that referenced this issue Nov 23, 2020
[#5726] Include requirements files in Manifest
amercader added a commit that referenced this issue Jan 15, 2021
Fixes #5726

This was missing from #5408, which allows installing the requirements
using pip, but didn't include the actual requirement files in the
published package, causing an exception when running `pip install ckan`
amercader added a commit that referenced this issue May 14, 2021
Fixes #5726

This was missing from #5408, which allows installing the requirements
using pip, but didn't include the actual requirement files in the
published package, causing an exception when running `pip install ckan`
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging a pull request may close this issue.

2 participants