cabal install roguestar-engine gives compilation error #37

Closed
prark opened this Issue Apr 3, 2011 · 3 comments

Projects

None yet

2 participants

prark commented Apr 3, 2011

Platform : OSx snow leopard
GHC 7
cabal-install version 0.10.2
using version 1.10.1.0 of the Cabal library

[36 of 57] Compiling DB ( src/DB.hs, dist/build/roguestar-engine/roguestar-engine-tmp/DB.o )

src/DB.hs:195:69:
Couldn't match expected type t0 -> t1' with actual typeforall (m :: * -> *). DBReadable m => a -> m b0'
The lambda expression \ x -> ...' has one argument, but its typeforall (m :: * -> *). DBReadable m => a -> m b0'
has none
In the second argument of ($)', namely\ x
-> do { y <- f x;
return (x, y) }'
In the second argument of ($)', namelyflip mapRO xs
$ \ x
-> do { y <- f x;
return (x, y) }'
cabal: Error: some packages failed to install:
roguestar-engine-0.6.0.0 failed during the building phase. The exception was:
ExitFailure 1

Owner
clanehin commented Apr 5, 2011

I tried to post a comment here last night, but the github's comment button was broken somehow. :(

This seems to be a GHC 7-specific issue. Whenever I get 0.6.0.1 up on hackage, it should be fixed.

Thanks,
--Lane

Owner
clanehin commented Apr 8, 2011

Should be fixed.

@clanehin clanehin closed this Apr 8, 2011
prark commented Apr 8, 2011

great Lane. It does compile now.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment