ReferenceError: version is not defined - when trying to precompile assets #1

Closed
ragulka opened this Issue Mar 6, 2013 · 2 comments

2 participants

@ragulka

Trying to run the express example, I get this error when trying to precompile assets:

Starting asset compilation

undefined:11
 buf.push('\n\nconsole.log(\'connect-mincer version: ', escape((3,  version() 
 ^
ReferenceError: version is not defined
    at eval (eval at <anonymous> (/Library/WebServer/Documents/node_projects/connect-mincer/node_modules/ejs/lib/ejs.js:234:12))
    at EjsEngine.toString (/Library/WebServer/Documents/node_projects/connect-mincer/node_modules/mincer/lib/mincer/engines/ejs_engine.js:52:19)
    at Context.evaluate (/Library/WebServer/Documents/node_projects/connect-mincer/node_modules/mincer/lib/mincer/context.js:438:33)
    at async.forEachSeries.iterate (/Library/WebServer/Documents/node_projects/connect-mincer/node_modules/mincer/node_modules/async/lib/async.js:108:13)
    at async.forEachSeries.iterate (/Library/WebServer/Documents/node_projects/connect-mincer/node_modules/mincer/node_modules/async/lib/async.js:119:25)
    at process.startup.processNextTick.process._tickCallback (node.js:244:9)
@clarkdave
Owner

Thanks, this should be fixed now. The precompile script was missing the 'version' helper but I've added it in now.

@clarkdave clarkdave closed this Mar 6, 2013
@ragulka

Yep, it works! Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment