Universal highcharts-more module for the popular JavaScript charting framework Highcharts
Switch branches/tags
Clone or download
Latest commit 6410e0c Jul 11, 2017

README.md

Highcharts-More

The universal highcharts-more module. This module can be loaded as an ES6, AMD, CommonJS or global module, in NodeJS or in the browser. It works with most modern module loaders (ES6, RequireJS, SystemJS). This package is generated based on the latest highcharts v5.0.12 release.

highcharts-more requires the highcharts module

What is Highcharts?

Highcharts JS is a JavaScript charting library based on SVG, with fallbacks to VML and canvas for old browsers. To avoid bloating the Highcharts core library, the Highcharts team deploy new chart types and features in a separate file called highcharts-more.js. In short, highcharts-more is extra functionality on top of Highcharts without modifying it's core code. It also allows you to use some charts types which don't exist in the "original" highcharts such as bubble, range, gauge and pollar charts.

Installation

$ npm install highcharts-more-node

Example Usage

Please note that there are several ways to use Highcharts. For general installation instructions, see the docs.

First, install the highcharts and highcharts-more packages.

$ npm install highcharts-more-node

Now import highcharts-more into your projects which will also import the highcharts core module.

// import Highcharts-More (no need to import `highcharts` since it's wrapped by `highcharts-more`)
import {Highcharts} from 'highcharts-more-node'
// OR
import Highcharts from 'highcharts-more-node'   


export class GaugeChartExample {

  constructor() {
  
    // create the chart
    Highcharts.chart({
      chart: {
        type: 'gauge' // available ONLY with highcharts-more
      },
      // ...................................
      // ... chart configuration options ...
      // ...................................
    });
  };
  
}
Helpful links