Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

upgrade mocha deps to avoid require 'mocha' deprecation

  • Loading branch information...
commit f56d105b98d907dd497c4d64d00eeec75a198e20 1 parent 035ff5f
@cldwalker authored
Showing with 2 additions and 3 deletions.
  1. +2 −2 .gemspec
  2. +0 −1  test/test_helper.rb
View
4 .gemspec
@@ -15,8 +15,8 @@ Gem::Specification.new do |s|
s.has_rdoc = 'yard'
s.rdoc_options = ['--title', "Bond #{Bond::VERSION} Documentation"]
s.add_development_dependency 'bacon', '>= 1.1.0'
- s.add_development_dependency 'mocha', '>= 0.9.8'
- s.add_development_dependency 'mocha-on-bacon'
+ s.add_development_dependency 'mocha', '~> 0.12.1'
+ s.add_development_dependency 'mocha-on-bacon', '~> 0.2.1'
s.add_development_dependency 'bacon-bits'
s.files = Dir.glob(%w[{lib,test}/**/*.rb bin/* [A-Z]*.{txt,rdoc} **/deps.rip]) + %w{Rakefile .gemspec .travis.yml}
if ENV['GEM_PLATFORM'] != 'java'
View
1  test/test_helper.rb
@@ -1,6 +1,5 @@
require 'bacon'
require 'bacon/bits'
-require 'mocha'
require 'mocha-on-bacon'
require 'bond'
require 'rbconfig'
Please sign in to comment.
Something went wrong with that request. Please try again.