Skip to content

Loading…

Ruby 1.9.3-p327 support #50

Closed
styx opened this Issue · 6 comments

5 participants

@styx

Hi, getting this error after upgrading to 1.9.3-p327:

Installing debugger-linecache (1.1.2) with native extensions 
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

        /home/user/.rvm/rubies/ruby-1.9.3-p327/bin/ruby extconf.rb 
checking for vm_core.h... no
checking for vm_core.h... no
@cr0t

If you have this issue with bundle install, you can try this workaround:

$ bundle
... -> failed to build debugger-linecache
$ gem install ruby-debug19
$ bundle
... -> all is fine
@alexeymuranov

I was getting this error, but

gem install debugger-linecache

worked for me.

@alexeymuranov

Oops, sorry, i think my error was different, but you may try running this anyway.

@styx

@cr0t @alexeymuranov thanks for your comments, will try tomorrow your solutions anyway, thanks.

@styx

@cr0t That helped, thnx.

@cldwalker cldwalker closed this in 478669f
@rsachdeva

@cr0t That helped, me too.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.