Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
ripl plugin for a multi-line ripl using ripper
Ruby
branch: master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
lib/ripl copy from ripl-misc and gemify
.gemspec
CHANGELOG.rdoc
LICENSE.txt
README.rdoc
Rakefile
deps.rip

README.rdoc

Description

This ripl plugin gives ripl multi-line eval ability using ripper.

Install

If on 1.9, install the gem with:

gem install ripl-ripper

If on 1.8, install the gem with:

gem install ripl-ripper ripper

Usage

Add to your ~/.riplrc

require 'ripl/ripper'

To customize your multi-line prompt use the :ripper_prompt option. For example,

Ripl.config[:ripper_prompt] = ' | '

Limitations

This gem is meant to run on 1.9. 1.8 support is completely up to the ripper gem. If that doesn't work for you, check out the ripl-multi_line plugin.

Something went wrong with that request. Please try again.