Permalink
Commits on Jun 13, 2017
  1. Merge pull request #89 from DexterTheDragon/remove_database_testing_i…

    …tems
    
    Remove database related items from testing
    committed on GitHub Jun 13, 2017
  2. Remove database related items from testing

    Since delocalize is no longer integrated with ActiveRecord there is no
    need to install sqlite gems or have a database.yml file for test.
    DexterTheDragon committed Apr 7, 2017
  3. Prepare 1.2.0 release

    committed Jun 13, 2017
  4. Update copyright

    committed Jun 13, 2017
  5. Remove legacy monkey patches

    Closes #88. Thanks @DexterTheDragon!
    committed Jun 13, 2017
  6. Merge pull request #86 from DexterTheDragon/remove_mocha

    Remove mocha gem
    committed on GitHub Jun 13, 2017
Commits on Apr 27, 2017
  1. Merge pull request #85 from DexterTheDragon/fix_parsing_of_invalid_dates

    Fix parsing of invalid dates
    committed on GitHub Apr 27, 2017
Commits on Apr 7, 2017
  1. Remove mocha gem

    DexterTheDragon committed Apr 7, 2017
  2. Keep original value in params if invalid

    Previously when delocalizing params, if a date was invalid, delocalize
    would either change the value to nil or an ArgumentError would be
    raised. This change makes it so that if an ArgumentError is caught
    during parsing then the original value is kept in the params hash. This
    way validations can be run against the invalid value.
    DexterTheDragon committed Mar 29, 2017
  3. Raise ArgumentError if date is invalid

    Previously delocalize would return `nil` if it parsed an invalid date
    within `default_parse`. This change makes it raise an ArgumentError so
    that it matches the behaviour of the other date parse methods.
    DexterTheDragon committed Mar 29, 2017
  4. Explicitly require ActiveSupport's version of Hash#slice to prevent i…

    …nconsistent behavior when testing across Rails versions
    committed Jul 21, 2016
  5. Make sure we have rake

    committed Apr 7, 2017
  6. Try with rbx-2

    committed Apr 7, 2017
  7. Fix typo; bundle again

    committed Apr 7, 2017
  8. Fix readme link

    committed Apr 7, 2017
  9. Update version support to reflect maintenance policies of Ruby and Rails

    - Ruby 2.1 and above are supported
    - Rails 4.2 and above are supported
    committed Apr 7, 2017
Commits on Jul 21, 2016
  1. Fix minitest warnings

    committed Jul 21, 2016
Commits on Jul 20, 2016
  1. Merge branch 'rails5'

    committed Jul 20, 2016
Commits on Jul 15, 2016
  1. Prepare 1.1.0 release

    committed Jul 15, 2016
  2. Add JRuby 9000

    - test Rails 5 against JRuby 9000 but not JRuby 1.7 since 9000 aims to be compatible with Ruby 2.2+ whereas 1.7 aims for 1.9.3 compatibility
    - also test Rails 4.1 and 4.2 against JRuby 9000 and keep testing it against 1.7 as well
    - don't test Rails 4.0 and 3.2 against JRuby 9000 but keep testing it against 1.7
    committed Jul 15, 2016
Commits on Jul 14, 2016
  1. Support both Hash and ActionController::Parameters

    The respond_to? check is needed since Rails 5 changed ActionController::Parameters to not subclass ActiveSupport::HashWithIndifferentAccess anymore.
    committed Jul 14, 2016
  2. Updated support matrix

    committed Jul 14, 2016
  3. Test against Rails 5

    committed Jul 14, 2016
Commits on Nov 12, 2015
  1. Fix gemfiles

    committed Nov 12, 2015
  2. Add version file

    committed Nov 12, 2015